PDA

View Full Version : Are you guys out of customer support agents!



o0R3D0o
02-17-2015, 01:38 AM
I have created a ticket on 26th of Jan, 2015 and still I didn't get a single reply! even one that notify me that an support agent had started looking to my issue!

What the hell you are thinking UBISOFT... just looking for our pockets! and don't give a sh!t about your service quality!




Reference Number: #02006818
I have unlocked the "Sword of Eden" and the "Eagle of Suger" but I can't equip them at all plus there is weapons that I bought but when switching them I have to re-buy them again!

This My System Specs:
► OS : Windows 8.1 Enterprise [64Bit]
► CPU : Intel Core i7-4820K OC'ed @ 4747MHz
► CPU Cooler : Cooler Master Nepton 280L
► GPU : MSI GeForce GTX 980 Gaming OC'ed @ 1501MHz/8002MHz
► RAM : G.SKILL RipjawsX OC'ed 2100MHz
► MBO : MSI X79A-GD65 (8D)

jeffies04
02-17-2015, 02:29 AM
This is a known issue. Most, if not everyone, has this problem from what I've seen.

Hopefully they fix it in an upcoming patch........

I agree support should be more forthcoming with information, even if it's a widespread issue.

Happyrooster.
02-17-2015, 10:27 AM
That's funny because I created a ticket the 28th of December I think and got answered on 2nd of January or something like that. Everything looks normal, except for the fact that they asked me for some info related to my computer, which I gave them asap and well, it's 17th of February and I still haven't gotten a response. Well played Ubisoft.

o0R3D0o
02-21-2015, 04:13 PM
The issue has been solved after the last update!