Thread: The Crew PC Stability & Crash Issues | Forums

  1. #181
    Ra1dM4X's Avatar Junior Member
    Join Date
    Sep 2013
    Location
    Stokmarknes, Norway
    Posts
    3
    Originally Posted by BownyAz Go to original post
    My game always crashes sometimes after 5mins, sometimes after 15mins
    but it keeps crashing....all the time
    tried almost everything but nothing helped me
    contactet support but no response

    recently bought a new pc
    My Specs are :
    Intel I7 6700K
    Asus Strix gtx 1070 -> driver 372.70 (tried older ones, did not help at all)
    16 ram
    asus z170a mainboard
    one ssd for the OS
    and one hdd with 7200rpm for the games I play
    pretty much the same specs and the same drivers and the game crashes after a short while was leading the first race by like 20 seconds then the game crashes just before i reach the finish line....really hope they fix this...even tho the game was free i'm not gonna spend time on a game that crashes frequently ...at this point i've had 5 crashes and spent more time in the intro splash logo screen that cant be skipped than playing the actual game
    Share this post

  2. #182

    Current hardware requirement

    The link in first post of this thread is 'not found'.
    I found that current requirements of hardware are described in
    C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\The Crew (Worldwide)\Support\Readme
    For video card,DX11 and shader model5.0 are reqired.
    GTX260,DX10 and shader model4.0,is no longer available
    Share this post

  3. #183
    t6nu's Avatar Junior Member
    Join Date
    Sep 2016
    Posts
    2

    game crash fix

    i had issues with game crashing right after i upgraded my gpu from amd 6950 to gtx 660ti. so when i turned v-sync off it didnt crash anymore. and after i turned it on it immediately crashed. I uninstall amd drivers with DDU before and cleaned all the temp stuff.

    EDIT: i deleted the my documents file and tried playing with v-sync on and it didnt crash atm. it might still crash on pvp tho. need to give it a try later.
    Share this post

  4. #184
    I've been having random hard crashes with a few soft crashes here and there no matter what i'm doing. Granted, my PC is not exactly powerful (FX4300 @4.5 Ghz, 8 GB DDR3 1600, HD7770) but is enough to run the game at 60 fps in low settings.

    At first i though it was my PC, so i cleaned it but i'm still having the same issue. Just finished the fist New York mission and i'm forced to reset my whole PC.

    I love this game, but it's seriously driving me nuts.
    Share this post

  5. #185

    poor performance

    35-45 fps and lower GTX 970 1920-1080
    Also got i5 4690k 4.3 GHz and 16 gb ram 2400 MHz. Can any1 help me ? Support just ignoring me another week.
    Share this post

  6. #186
    After one week of google, searching forums for solution, writing to support (with they don't answer), updating my programs software and full reinstall of windows, verify game, reinstalling and other methods provided by good people here ( thanks for your words)

    GAME WON'T EVAN START!!!!!!!!!!!!!!!!!! SHAME ON YOU UBISOFT FOR MAKEING GAMES THAT DONT EVAN START, NEVER GONNA BUY GAMES FROM YOU EVER. I WANT MY MONEY BACK!!!!!!!!!!!!!!!!!!!
    Share this post

  7. #187

    Crashing while playing

    I crash all the time. Have done everything this thread has suggested. I have friends that don't crash at all and can play all day. I'm not even sure why I care anymore. Its obvious at this point that there is no fix coming. Ubisoft has moved on to more games that they can sell. Fixing past games doesn't net them money. I'll say this however, there is no way I'm buying Wild Run DLC if the main game wont run for more then 20 minutes. I miss the good ol days when companies focused on making a game that lasted, not making a game they can stack DLC, and Micro-transactions on. For shame.


    My System:

    Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
    16GB DDR4 RAM
    64-bit OS
    GeForce GTX 970 (Driver Version 373.06)
    2TB Hard Drive
    1TB Hard Drive
    OS running on 250GB SSD.

    Temps are all in the Green.
    Share this post

  8. #188

    I face the same prob here too , my Rig handles the game well at 60 fps despite of using ultra settings, but it crashes all of a sudden with no error messages at all, and my pc becomes usable only when I restart it
    Share this post

  9. #189
    gts.123's Avatar Member
    Join Date
    Jan 2014
    Location
    Surrey, UK
    Posts
    67
    I went through UbiSoft support, including escalation which took about a month, and in the end they just said my ntdll.dll was corrupt and causing the problem - all they did is read this from the crash reports included in my msinfo file. However MS file checker finds no problems with any system files including ntdll.dll, and ntdll.dll errors are more of a symptom than a diagnosis.
    I would be interested if everyone else suffering with these crashes also has similar crash reports in their Windows event viewer?
    Faulting application name: TheCrew.exe, version: 1.2.0.0, time stamp: 0x58bef6d2
    Faulting module name: ntdll.dll, version: 10.0.14393.479, time stamp: 0x5825887f
    Exception code: 0xc0000005
    Fault offset: 0x000000000003cad9
    Faulting process id: 0x2a64
    Faulting application start time: 0x01d2d2733f0c8ee6
    Faulting application path: F:\GAMES\The Crew (Worldwide)\TheCrew.exe
    Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
    Report Id: 52c4d7a6-aa35-4765-a637-86381fc906bf
    Faulting package full name:
    Faulting package-relative application ID:
    Share this post

  10. #190
    gts.123's Avatar Member
    Join Date
    Jan 2014
    Location
    Surrey, UK
    Posts
    67
    OMG - can it really be so simple? Having read through this entire 19 page thread again I saw quite a few people saying that having less friends in Uplay stopped the crashing for them. I decided to try it and took my friend list down to 40 from 109 - and for the first time in ages I played for over two hours without a single crash! I did many chases and PvP - unheard of to do this without a crash! And even when I closed the game it closed properly (usually get a crash when exiting).I dont know if tomorrow will be the same, but this could be why for no apparent reason the problem first started - I just added one too many friends. There must be some tipping point, and any more than this magic number causes problems?
    So much for Ubi support saying my ntdll.dll was corrupt :-)
    Share this post