Results 1 to 4 of 4

Thread: Assassin's Creed Liberation HD ac3lhd_32.exe error | Forums

Assassin?s Creed Unity ? Wear the Phantom Blade Replica

Assassin?s Creed Unity Cast of Characters Trailer [US]

Assassin?s Creed Unity Story Trailer [US]

Assassin?s Creed Unity Experience #2 Customization & Co-op [US]

  1. #1
    Junior Member
    Join Date
    Dec 2012
    Posts
    3

    Exclamation Assassin's Creed Liberation HD ac3lhd_32.exe error

    Okay, so I pre-ordered the AC Liberation HD and played it on the day it was released, however, the next day, when I tried playing it again, the game just enters a black screen and when I returned to the desktop page, an error window came up saying, "ac3lhd_32.exe has stopped working" I'm a little frustrated cause I seriously wanna play it so can someone please tell me how to fix this problem? (BTW, I already tried uninstalling and reinstalling the game but it doesn't seem to work...)
    Reply With Quote Reply With Quote

  2. #2
    Same issue here. Had to log out from task manager, logged back into the game and could play a while before it crashed out and I had to repeat the process. At least that was the case until the last time it did it. Then I logged back in to find that my save was now "damaged" and I had to start from zero again...I am all for replaying a game, but I prefer to actually get it completed before I restart all over gain.
    Reply With Quote Reply With Quote

  3. #3
    You know you can make backups? Some log from the crash might also be useful.
    Reply With Quote Reply With Quote

  4. #4
    Junior Member
    Join Date
    Dec 2012
    Posts
    3
    Actually, I asked my brother for help and he updated my nvidia graphic card (through online) and now, the error is gone, thx for the help anyways =)
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •