Results 1 to 5 of 5

Thread: [PS4]Time Saver: Resource Pack not working. | Forums

Assassin?s Creed Unity ? Wear the Phantom Blade Replica

Assassin?s Creed Unity Cast of Characters Trailer [US]

Assassin?s Creed Unity Story Trailer [US]

Assassin?s Creed Unity Experience #2 Customization & Co-op [US]

  1. #1

    Time Saver: Resource Pack not working.

    I recently purchased the Time Saver: Resource Pack and I have still not received the items or the extra space. It says I have to reach Sequence 3 Mission 4 for it to activate. But I'm on Sequence 4 Mission 4 and I still not receiver anything. I'm honestly disappointed since I payed $1.99 which isn't very much, but still money. I'm just asking for a solution for my problem.
    Reply With Quote Reply With Quote

  2. #2
    I'm having the same problem. Bought the technology time saver pack. I'm in sequence 4 and the upgrades still say that the plan is required. How do you get this working?
    Reply With Quote Reply With Quote

  3. #3

    Angry Resource Pack not working

    The resource pack is not working for me as well. I'm past Sequence 3, Memory 4 and it gives me an error saying I don't have enough cargo space. It goes on to say that it'll be available the next time I play the game. I've logged out and back in several times with no success. I went to Sony support first and was directed to Ubisoft's phone support. The tech at Ubisoft told me he'd never heard of this issue. I'm seeing that this issue goes back to at least November of last year. Now, I'm getting upset because it appears this issue has been around long enough for Ubisoft to have fixed it. This has cost me money and I either want the product I purchased or I want the money back on what I purchased.
    Reply With Quote Reply With Quote

  4. #4
    Junior Member
    Join Date
    Mar 2014
    Posts
    3
    Finally found something on this. I'm having the same problem, sucks to find out it's been going on since November. This DLC works fine on the 360, so there's no reason they shouldn't be fixing it for the PS4. What a bummer.
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    Jul 2009
    Posts
    2

    Exclamation TIme savers do not activate

    You wrote:
    UPDATE: I solved this, you are supposed to go to PSN > downloads > AC4 and install manually each of your packs. Then restart the game and it works.

    Hi,


    I have purchased the following from the PSN Store:
    - Time saver collectibles pack
    - Time saver activities pack
    - Time saver technology pack


    The problem is they do not activate in game. I still need the plans for elite upgrades, I still don't see all collectibles and locations in game. If I browse the packs in menu they show as purchased.


    I have also bought the resource pack a few times and it always activated the next time I entered the story.

    Does anyone have a solution to this?

    Thanks.
    Last edited by nevrozel; 07-04-2014 at 11:42 AM.
    iMac Core i5
    8GB DDR3
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •