Results 1 to 7 of 7

Thread: [XB360]Unable to unlock Altair, Ezio, and Connor's outfits in AC4 | Forums

The Assassin's Creed Experience - Comic-Con Day 3

Assassin?s Creed Unity Arno Master Assassin CG Trailer [US]

The Assassin's Creed Experience - Comic-Con Day 2

The Assassin's Creed Experience - Comic-Con Day 1

  1. #1
    Junior Member
    Join Date
    Jan 2013
    Posts
    4

    Unable to unlock Altair, Ezio, and Connor's outfits in AC4

    I have completed AC3 and most of AC2. Both are linked to my uplay account, but still when I launch AC4 (on Xbox 360) it does not give a message saying I have unlocked Altair's outfit. I really want to unlock Connor's outfit but if it does not even work them I'm not going to buy Brotherhood or Revolations to have played three AC games. Any suggestions?

    Thanks
    Reply With Quote Reply With Quote

  2. #2
    I've played all the major games with all linked to my account. Still no outfits for me too. A lot of people haven't got them it seems. Sorry, but I've no advice for you other than to say you aren't alone.
    Reply With Quote Reply With Quote

  3. #3
    I have downloaded from Steam all the AC Saga (From AC1, to AC Black Flag, including Revelations, Brotherhood and Liberation HD), and according to the info ubisoft gave, If you synchorinze all your games to uplay, as long as you have played at least 3 of them long enough to make uplay recognize 1 achievement, the game will automatically unlock 3 special outfits for the single player campaign (Altair, Ezio an Connor outfits), but in my case, the outfits didn´t unlock at all, no one of them. So i tried to advance more in the game to see if that unlocs them, but nothing happened, then i tried to connect to the other online services (Multiplayer, AC Ininiates, Kenway´s Fleet, etc.) and i did it without any other problem to consider, so i contacted ubisoft support and told them my issue but they just told me that it was a bug, so i found it usseful to report this on this forum too. (By the way i've been reading the formus and according to them, if youre playing on a XBox or a PS, these is a way to solve it, you only need to unlink your account, and link it back, and voila!!! problem solved, but in PC you can´t do this so.. i hope someone read this and really trye to fix this out)
    Reply With Quote Reply With Quote

  4. #4
    Junior Member
    Join Date
    Jan 2013
    Posts
    4
    jhonatandavis8 Thanks so much for the fix to the problem!!! It sucks that it is not possible to do that with PC though. The times I have contacted Ubisoft support they have never helpful and I go to the forms for help.

    Thanks again and I hope they fix the problem for PC.
    Reply With Quote Reply With Quote

  5. #5

    Still nothing

    Apparently they still haven't fixed this issue? I've played through 1,2,Brotherhood,Revelations, and 3 have redeemed uplay rewards from all but revelations and still no outfits. I somehow have Altair's robes tho, not sure how I got it... but the others are not showing up. And as too johantadavis how do you unlink your uplay from your gamertag or psn? I cant seem to do this and there is no option anywhere to allow me to do so. Ubisoft is pissing me off so much with this extra BS lately. Community challenges(that aren't running atm anyways), social events, Kenways fleet missions are ridiculously long(I know friends can speed them up but this is a video game not a social media network wtf), not to mention I bought freedom cry and the "special reward" for liberating 500 slaves has nothing to do with the actual story, dumbest stuff ever I swear
    Reply With Quote Reply With Quote

  6. #6
    AC Expert Ureh's Avatar
    Join Date
    May 2009
    Posts
    2,836
    There're some issues with the Uplay servers at the moment (possibly due to the Watch_Dogs launch). So some of the AC4 social/online stuff may be affected as a result.

    To unlink an psn/xbl acc then relink them you'll need to go to uplay.ubi.com. Sign in, at the top-right corner under your uplay username should be an account settings button (with a gear icon). Scroll all the way to the bottom of the page and you should see the psn/xbl account and option to unlink it.
    Reply With Quote Reply With Quote

  7. #7

    thanks

    ok so is that why I can't even get into uplay? I'll just try again later then and see what happens. Thanks for quick response
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •