Thread: Assassin's Creed IV Black Flag update problem. | Forums

  1. #1

    Assassin's Creed IV Black Flag update problem.

    When ever new update comes problem arises. when the game start updating it says " There is a problem connecting to the internet. Please check your network settings. we will restore the connection as soon as we can." And the downloading speed goes down to 0kb/s. Please solve this problem.
    Share this post

  2. #2
    I get this message too, but the download continued. Are you sure your download stopped?
    Share this post

  3. #3
    I got this message too, but the download continued. Are you sure your download stopped?
    Share this post

  4. #4
    My ac version still 1.2 and dont run update to 1.3 lol...when ppl arleady play dlc characters in MP...i go to MP with 1.2 and see this,lol.Idk what this patch do...But finally i got Season pass but cant play new content with 1.2
    Share this post

  5. #5
    it's better to say that my download stopped because after almost 1hr it shows only 1MB downloaded.
    Share this post

  6. #6
    I get a similar problem.

    UPlay tries to download the update 1.03 but speed in download window says 0b/s although data is transferred all the time.

    I monitor the connection in my router. This is going on for 3 hours now. I guess the download algorythm of the uplay client is not the best.

    Could you please investigate Ubisoft?
    Share this post

  7. #7
    According to my monitoring nearly 450MB were downloaded in the last 40 Minutes. However Uplay only registered 20MB in the same time.

    Something is definitely wrong here!
    Share this post

  8. #8
    nj473's Avatar Junior Member
    Join Date
    Apr 2012
    Posts
    20
    Yes, thank you for posting this, I came on here thinking I was the only person having this issue! When I try and download the patch, the download speed is ridiculously slow and keeps going back to 0kb/s, then I get the message. I left my PC on all night and I barely got 10MB! Also, this download through Uplay seems to actually disconnect my router after a while for some reason. I know my internet is not great and it shouldn't do that at all, but I have never had that problem with anything else, just Uplay. I actually had to take my PC to a friends house to get the 1.02 patch when it came out because it was so bad.

    Anyway, long story short, this download process does not work for some people. Is there any way of obtaining the 1.03 patch outside of Uplay?
    Share this post

  9. #9
    nj473's Avatar Junior Member
    Join Date
    Apr 2012
    Posts
    20
    Originally Posted by nj473 Go to original post
    Anyway, long story short, this download process does not work for some people. Is there any way of obtaining the 1.03 patch outside of Uplay?
    Just answered my own question by asking Ubi support; no there isn't a way outside of Uplay.
    Share this post

  10. #10
    im having the same problem! it actually pretty annoying. i cant play multiplayer because of this. everytime i join a game it crashes on me. havent played a single MP game once . has anyone found a solution for this?
    Share this post