Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: How to improve my NAT | Forums

Assassin's Creed® Freedom Cry Gameplay Walkthrough Trailer [UK]

Freedom Cry DLC Launch Trailer | Assassin's Creed 4 Black Flag [UK]

Official Accolade Trailer - Assassin's Creed 4 Black Flag [UK]

Multiplayer Features Trailer | Assassin's Creed 4 Black Flag [UK]

  1. #1

    How to improve my NAT

    Just bought AC 4.

    Sorry guys, i searched all forums, all links are either dead or missing.

    I got 4MBPS connection. PC player. Please let me know how to improve my NAT.

    Thx.
    Reply With Quote Reply With Quote

  2. #2
    Senior Member
    Join Date
    Mar 2012
    Location
    Wales
    Posts
    517
    Quote Originally Posted by desmond2192 View Post

    I got 4MBPS connection. PC player. Please let me know how to improve my NAT.

    Thx.
    You, sir. Need better internets.
    PSN = LocalWin
    Reply With Quote Reply With Quote

  3. #3
    4MBPS is not better internet?
    Reply With Quote Reply With Quote

  4. #4
    Senior Member DomdudeDaGreat's Avatar
    Join Date
    Dec 2012
    Location
    London, Somewhere over the Rainbow
    Posts
    1,337
    Yeah, hate to say it but 4MPS is pretty bad. I get over 10x that using a wired connection


    Are you using a wireless connection? If so you might want to invest in an Ethernet cable. If you already have one then sorry, time for a new ISP :P
    I would also like to point out that with my connection i only get an Orange NAT on AC Multiplayer. It is just as much Ubisoft's fault as it is yours trust me.

    Youtube --- Twitter --- Google+ --- Ubi Forums --- Nos/L2K
    PSN : DomdudeDaGreat ACB: Level 50 ACR: Prestige 15 AC3: Prestige 35 AC4: (PS3) Prestige 6 (PS4) Prestige 10
    BRING BACK THE OLD ASSASSINATE

    Please direct all love/hate/death threats/queries here ---> domdudetehgreat@gmail.com
    Reply With Quote Reply With Quote

  5. #5
    Reply With Quote Reply With Quote

  6. #6
    I had a Moderate NAT on my XBOX ONE and I finally fixed it by disabling a firewall setting within my router. You may want to investigate that.
    Reply With Quote Reply With Quote

  7. #7
    Junior Member
    Join Date
    Nov 2013
    Posts
    7
    I'm ecstatic right now since I've figured out how to fix NAT issues in not just AC,but all games. First obviously make sure you have UPnP enabled, or your ports forwarded (I use both,hasnt caused problems) Inbound and outbound firewall rules are set for both multiplayer and singleplayer. now those alone didn't fix my problem. I even tried disabling my router firewall. The fix I found was:

    - go to www.speedguide.net and download TCP Optimizer

    -Once that's downloaded,run as administrator and set the connection speed to the spped your ISP has provided for you, check modify all network adapters, check the "Optimal" setting, click apply changes, reboot.

    -Go to pingtest.net and check out your ping. Before I did the above steps I was at a 64/mbs network speed which isnt bad at all, but applying the changes reduced my ping by 40/mbs. I'm at 23/mbs after the changes.

    -Go to AC multiplayer and check your NAT Status.

    -Note that for the above to work, it is recommended that you already have good bandwidth.

    -This fix is for PC
    Reply With Quote Reply With Quote

  8. #8
    Rtluv that doesn't do anything whatsoever to effect NAT

    whatever fixed your problem was something else
    Reply With Quote Reply With Quote

  9. #9
    Senior Member Anykeyer's Avatar
    Join Date
    Dec 2009
    Posts
    2,013
    enable UPNP in your router's settings
    OR
    forward port 3074 UDP in your router's settings (this is the only port game actually uses for P2P, the only one it forwards with UPNP and the only one used to test your NAT in game).

    If this does not help try disabling firewall. If even this isnt enough its time to change your ISP
    Last edited by Anykeyer; 01-02-2014 at 08:59 AM.
    You sure, you're right? Well no, you're wrong. You don't feel my energy. But it won't be long
    Reply With Quote Reply With Quote

  10. #10
    I wish that were the truth but I've already confirmed that I have port 3074 open in a port checking program. Perhaps having that port open can get you to moderate from strict but for me, it will not be open.

    I have tested each of the ports listed here:
    https://support.ubi.com/en-GB/FAQ.as...0000000eaegCAA


    Those ports are all open, despite that I've still yet to ever see an Open NAT in Black Flag.

    I can even start up Assassin's creed 3 MP and have an open NAT in that, which only serves to add to my frustration.
    Last edited by Pessticool; 01-02-2014 at 11:27 AM.
    Reply With Quote Reply With Quote

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •