Results 1 to 6 of 6

Thread: Rocksmith 2014 - LatencyBuffer=1 Does it work? | Forums

Rocksmith 2014 Edition - The Smashing Pumpkins' "Cherub Rock"

How Guitar Teachers Can Use Rocksmith 2014 Edition

Rocksmith 2014 Edition -- How It Works -- Learn How To Play Guitar In 60 Days

Rocksmith 60-Day Challenge -- Trevor's Success Story -- Learn How To Play Guitar In 60 Days

  1. #1
    Member
    Join Date
    Jan 2013
    Location
    Istanbul
    Posts
    36

    Rocksmith 2014 - LatencyBuffer=1 Does it work?

    Is there anyone who can run Rocksmith 2014 PC version while LatencyBuffer is set to 1 ?

    On my PC it does not work properly even when MaxOutputBufferSize is set to 1024 and my PC is rather highend.

    i7 3820 @ 4.2 GHz
    8GB 1866MHz DDR3 Ram
    Xfx 7970 Black DD Edition.
    Gigabyte X79S UP-5

    When LatencyBuffer is set to 2, I can also set MaxOutputBufferSize to 136 and everything works perfectly. This is the smallest lag I can get on my PC and setting MaxOutputBufferSize to 128 or smaller results in no sound at all.

    Can anyone set Latencybuffer to 1 and what configuration do you have?
    Reply With Quote Reply With Quote

  2. #2
    Senior Member KinchBlade's Avatar
    Join Date
    Nov 2011
    Location
    Dublin, Ireland
    Posts
    2,623
    This is very interesting because I just tried this over the weekend and could not make Buffer=1 work without crackling with any buffersize
    My pc could run RS1 with Buffer =1 and Buffersize of 128.
    When I set Buffer was 2, all I got was silence. But at that point I was running out of time and put it back to stock. So my experience with Buffer=2 may be my own fault.
    So I too would be interested to hear if Buffer =1 is working for anybody...
    Last edited by KinchBlade; 11-11-2013 at 05:59 PM.
    If you say 'gullible' slowly it sounds like 'oranges'.

    UPlayID: KinchBlade SteamID: KinchBlade
    Reply With Quote Reply With Quote

  3. #3
    Senior Member KinchBlade's Avatar
    Join Date
    Nov 2011
    Location
    Dublin, Ireland
    Posts
    2,623
    Played around with this a little more tonight (instead of actually playing around with the guitar!)
    Only if I set Win32UltraLowLatencyMode=0 then I can set buffer=1 and BufferSize=148 and it'll start up without without crackling
    I don't know if this is 1 step forward and 2 back or not though since according to the pdf that is turning off latency handling improvements in 14
    If you say 'gullible' slowly it sounds like 'oranges'.

    UPlayID: KinchBlade SteamID: KinchBlade
    Reply With Quote Reply With Quote

  4. #4
    I really wish there would be a word from the developers about that Win32UltraLowLatencyMode. It seems not to work in many cases on real world PCs, is a special version of Windows needed?

    They want us to fiddle in .ini files so they should give us information. Also it would have been a nice thing to make some in game configuration to switch this, maybe as a kind of multiple choice "Do you hear your guitar clearly?" "NO? I switch off.... blblbla".

    Carsten
    Reply With Quote Reply With Quote

  5. #5
    I use a latency buffer setting of one. But could only do so when playing in non-exclusive audio mode and increasing the max output buffer size slightly

    Shared Mode:
    Code:
    [Audio]
    EnableMicrophone=1
    ExclusiveMode=0
    LatencyBuffer=1
    ForceDefaultPlaybackDevice=
    ForceWDM=0
    ForceDirectXSink=0
    Win32UltraLowLatencyMode=1
    DumpAudioLog=0
    MaxOutputBufferSize=576
    Exclusive Mode:
    Code:
    [Audio]
    EnableMicrophone=1
    ExclusiveMode=1
    LatencyBuffer=2
    ForceDefaultPlaybackDevice=
    ForceWDM=0
    ForceDirectXSink=0
    Win32UltraLowLatencyMode=1
    DumpAudioLog=0
    MaxOutputBufferSize=144
    Of note is that in exclusive mode, even though a latency buffer of 2 is needed (distorted sound with 1 regardless of max output buffer size), the overall latency should be smaller than the shared mode which needed a much larger output buffer. Both settings are very playable although I prefer exclusive mode unless I want to record a play through with shadow play.

    I'd assume that a higher output buffer size and/or latency setting would be preferred over disabling the low latency mode, but that's only based on what the PDF said, no idea how big a different the mode savings are. For what it's worth, Mac users have a better time of it (putting aside graphical issues and general stability), no setting to change other than LatencyBuffer in the ini and a setting of 2 is as playable as the best tweaks I've managed in Windows without the tweaking hassle. Shame the game crashes nearly every time I try it on the mac, but when it does run, the audio is great

    The above settings are with an i5 3570 and a gigabyte GA-B75-D3V board which I think uses realtek audio.
    Last edited by GaryRS1; 11-13-2013 at 12:05 PM.
    Reply With Quote Reply With Quote

  6. #6
    Senior Member KinchBlade's Avatar
    Join Date
    Nov 2011
    Location
    Dublin, Ireland
    Posts
    2,623
    Cool - If I ever get free time again - I 'll give that a try instead.
    So, so far it seems that 100% of respondents are having no luck with simply setting Buffer=1 without additional changesto "unrelated" parameters...
    If you say 'gullible' slowly it sounds like 'oranges'.

    UPlayID: KinchBlade SteamID: KinchBlade
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •