Results 1 to 10 of 10

Thread: Assassin Contracts Bug (360) | Forums

Assassin?s Creed Unity Cast of Characters Trailer [US]

Assassin?s Creed Unity Story Trailer [US]

Assassin?s Creed Unity Experience #2 Customization & Co-op [US]

Assassin?s Creed Unity Season Pass Trailer [US]

  1. #1

    Assassin Contracts Bug (360)

    (Salt Key Bank - Contract 28) "Shady Business"

    Okay I found this guy but lost sync being killed by a hunter, and then it reloaded like usual. I found the target again just standing on the Matanzas dock. Fired at him but nothing happened. I jumped off my ship to reach him and as I approached he vanished. Now there is a "Red dot" Target & Distance for Juan Garcia all the time in game and on map and I can't find or even see him to complete this contract. Is this happening to others? Would rather not delete the one and only save. I tried clearing the cache but I fear it's a corrupted file. Sorry for the long message.

    Thanks.
    Reply With Quote Reply With Quote

  2. #2
    i have the same problem with contract 12 (a botched escape) in Havana went to do it but failed as he got away so carried on with the game when it came back on the world map i went back but when got there the marker went yet the red location stayed i have done everything else but this one contract. i have loved the assassins creed games so far but black flag has to be the best so far so if ubisoft can fix it it would be great thanks
    Reply With Quote Reply With Quote

  3. #3
    I think we are the only few unlucky ones I have the exact same problem as you and I want to get Pistol Swords early in the game but this bug just turned me down, hope ubisoft will fix this soon!
    Reply With Quote Reply With Quote

  4. #4
    I got the bug and i activated the contract but never tried to kill him eventually he just disappeared and never re spawned i started doing the contracts after i beat the game put 27 hours into the game before i noticed it was glitched and not one word from ubisoft about the glitch i doubt they will patch it assassins creed is not known for its amazing patches
    Reply With Quote Reply With Quote

  5. #5
    US Forum Manager
    Spartacus Legends CM
    Black_Widow9's Avatar
    Join Date
    Apr 2007
    Location
    U.S.
    Posts
    10,696
    We are working on a fix for this right now.
    Reply With Quote Reply With Quote

  6. #6
    I also am having issues with this contract. I accepted the contract very early in game and completely forgot about it (not sure if I attempted it or not) and now my screen just says kill your target but no red skull marker. I go to where contract suppose to happen and nothing happens, I'm at 83% complete on Xbox 360. Please somebody help me!
    Reply With Quote Reply With Quote

  7. #7
    Quote Originally Posted by Black_Widow9 View Post
    We are working on a fix for this right now.
    What about contract 29 The Smugglers Squat? I go in there and there is no target. This is the last contract I have and I want those pistol blades.............
    Reply With Quote Reply With Quote

  8. #8
    Community Manager Mr_Shade's Avatar
    Join Date
    Nov 2009
    Location
    United Kingdom
    Posts
    19,508
    The team have attempted to fix any and all contract issues - even those not yet reported before they wrote the patch, so hopefully it will be covered.
    Reply With Quote Reply With Quote

  9. #9
    I have the Exact same issue. That red dot with "no Juan" is driving me crazy! Please help
    Reply With Quote Reply With Quote

  10. #10
    Is there any indication when the fix will be available?
    Staying independent is the goal to creativity!
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •