Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: Sequence 8 Memory 2 (Mission Name: Vainglorious Bastards) | Forums

Assassin's Creed Unity Make History Trailer [US]

Assassin?s Creed Unity ? Wear the Phantom Blade Replica

Assassin?s Creed Unity Cast of Characters Trailer [US]

Assassin?s Creed Unity Story Trailer [US]

  1. #1

    Sequence 8 Memory 2 (Mission Name: Vainglorious Bastards)

    I am going for the 100% sync of all story missions and I am unable to get the 100% sync on this mission, the game is not registering one of the optional objectives. The objective that I believe to be glitched is "Damage the Royal African Pearl with an upgraded ram." I have a fully upgraded Jackdaw so I know that I have the best ram available, I have also destroyed all of the legendary ships to unlock the ability to do a "super ram".
    Reply With Quote Reply With Quote

  2. #2
    Junior Member
    Join Date
    Nov 2008
    Posts
    8
    I have the same problem as you. Also have all upgrades and beat all the legendary ships. Tried it a dozen times but I've been unable to get the objective done.
    Did you find anything useful since you discovered the glitch?
    Reply With Quote Reply With Quote

  3. #3
    Exactly the same problem so annoying.This is the last mission i need to do to get 100% sync
    Reply With Quote Reply With Quote

  4. #4
    Junior Member
    Join Date
    Nov 2008
    Posts
    8
    I have continued with a 78% save (was 99% dammit) and was able to do it 100% now. My ship now wasn't fully upgraded yet and I didn't get the ram boost for defeatin all legendary ships yet. @ Allum, did you defeat all legendary ships? I think that might be what's causing it.
    Reply With Quote Reply With Quote

  5. #5
    @ Nick. Yh i have and i have a fully upgraded Jackdaw
    Last edited by Allum_1994; 11-07-2013 at 11:34 PM.
    Reply With Quote Reply With Quote

  6. #6
    Not sure if it will be off help.

    But i was able to do these constraints with a fully upgraded Jackdaw, before defeating all the legendaries and attaining the ram boost.
    Reply With Quote Reply With Quote

  7. #7
    Junior Member
    Join Date
    Dec 2013
    Posts
    1
    I'm having the same problem with a fully upgraded ship and all legendary ships defeated.
    Reply With Quote Reply With Quote

  8. #8
    I as well am having this issue, and after trying multiple times, have had no more success than I did the first time. I tried to bring it up on the report page, but it will not allow me to send in any of my questions. I don"t have another save to load, and I certainly don't want to restart my progress from the beginning. Hopefully there will be an update for this soon, or I may be forced to completely restart,
    Reply With Quote Reply With Quote

  9. #9
    Having the same problem. Stuck at 99%. I can't submit a bug report, and I can't submit a thread in the bug forums due to a weird glitch, so I figured I'd just bump this thread. Was kind of hoping for it to be fixed in today's Xbox One patch.
    Reply With Quote Reply With Quote

  10. #10
    Figured i'd bump this topic
    Reply With Quote Reply With Quote

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •