Thread: Windows 8.1 | Forums

  1. #1

    Windows 8.1

    DO NOT UPGRADE this OS doesn't work you will find you shall lose some apps or programs and Microsoft won't accept responsibility for the troubles you will experience. I am talking from experience as I lost the ability to start M&M VI which played well on Windows 8 but can't be started on 8.1. Microsoft blamed Ubisoft and refused to help me return to Windows 8. I have been in touch with others who have had problems with the upgrade as well.I had trouble with my browser at first, but managed to clear that up.
    Share this post

  2. #2
    Well, M$ doing their usual stuff. Good-****-Good-****.

    95 = ****
    98 = Good
    ME = ****
    XP = Good
    Vista = ****
    7 = Good
    8 = ****

    Just don't buy into their crap, and they will release a next OS in no time, which will hopefully continue the tradition and be good. With new replacement tech for DirectX in the works, I hope we get rid of "new DX effects only on latest windows OS" crap and be free from the MS tyranny totally.

    PS: Thanks for informing people btw, probelms are not only refusal to start apps, but mouse delay and multiple other issues as well. And no, M$ never takes responsibility for anything, but you always have to pay them money...
    Share this post

  3. #3
    The game works fine for me with Windows 8.1.

    I have heard some other ppl have problems with mouse cursor with older games, and a lot more. But I have been lucky so far.
    Share this post

  4. #4
    At the beginning I had some problems with Windows 8.1... then I reinstalled the Nvidia drivers with the latest for windows 8.1 and reinstalled MMX game runs fine now no problems anymore. I suggest that Ubisoft will come with a patch to fix issue's related to OS etc... it was a while ago that we had any game updates
    Share this post

  5. #5
    I've had zero issues with Windows 8.1. Running M&M X Legacy on a Surface Pro 2. Great game for touch screens.
    Share this post

  6. #6
    There is a problem with most games for users who updated from Win 8 to 8.1 and have Nvidia cards but it is easily fixed. The default Win 8.1 Nvidia Driver enables 3d spectroscopic support, just go into the Nvidia Control panel and Unclick "Enable Sterescopic 3d" box.
    Share this post