Results 1 to 9 of 9

Thread: Uplay not connecting to internet | Forums

  1. #1
    Junior Member
    Join Date
    Dec 2011
    Posts
    15

    Thumbs up Uplay not connecting to internet

    Starts up fine... get's to the part where it says "Updating Uplay" and then starts to b*tch and moan at me that I have an issue with my internet connection : / So much for playing my game online through some shoddy and superfluous service. If this is a server issue on Ubi's side, get some backup servers ffs. I can't imagine Steam doing something like this... The same bs with save games being "synchronized with the cloud", half the time it fails for 'some' reason :S

    People pay for a product which they can't use (for 100%) because you won't let them due to an unstable service. Invest in a better one, it's your responsibility as a company to not only provide working products but also a working service if it's mandatory for said products to work properly. If you can't guarantee near 100% up time with said service you should not make it mandatory and shove it down costumers throats. Let people play your games in offline mode with the same perks as in online mode if those perks do not necessarily require a constant online connection. The only thing your broken Uplay service does is promote piracy, at least then you can play unhindered and whenever you want without some watchdog program running in the background..

    EDIT:
    I've removed and reinstalled Uplay, now I can't go into offline mode because "If this is your first time using Uplay on this computer (which it isn't) you need to log in at least once before using offline mode". Great, so now no offline play either because Uplay fails big time at my expense! No my internet is perfectly fine, nothing about it changed since I played last night.
    Last edited by royjussen; 07-13-2013 at 12:34 PM.
    Reply With Quote Reply With Quote

  2. #2
    Junior Member
    Join Date
    Feb 2012
    Posts
    6
    same here, btw : your forum is a complete mess too.
    Reply With Quote Reply With Quote

  3. #3
    Community Manager Ubi-Mush's Avatar
    Join Date
    Nov 2011
    Location
    CRC Newcastle-Upon-Tyne, UK
    Posts
    16,392
    Ubisoft Community Manager

    Technical Support
    Twitter Support
    Facebook Support

    Reply With Quote Reply With Quote

  4. #4
    cant connect either, and neither to the website of uplay, its shown incorrectly.
    i think the servers arent working correctly.


    edit: support site and uplay site have a white background and every element is shown as a list here

    btw connecting to the forums wasnt easy either :/
    Last edited by cryptic137137; 07-13-2013 at 01:57 PM.
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    May 2006
    Posts
    4
    Same situation as OP here. It was working fine yesterday... Not been able to log in for hours. Uninstalled Uplay but now I can't even download it from the uplay site. The site itself is not loading correctly and the uplay installation file is not found. Have a proper look into it Ubi, instead of reading half of the original post and giving us the useless standard support reply...
    Reply With Quote Reply With Quote

  6. #6
    Junior Member
    Join Date
    Dec 2011
    Posts
    15
    Quote Originally Posted by cryptic137137 View Post
    cant connect either, and neither to the website of uplay, its shown incorrectly.
    i think the servers arent working correctly.


    edit: support site and uplay site have a white background and every element is shown as a list here

    btw connecting to the forums wasnt easy either :/
    I get the same stuff. A lot of images on the forums aren't showing either.
    Reply With Quote Reply With Quote

  7. #7
    Uplay is a mess the website is olso a mess.
    yesterday it wasnt.
    didt all what u asked me to do.
    And still no Internet connection.
    olso i got a new load screen for u Play.
    so if u are updating why not say it.
    now a lot of gamers are freaking out just because a lack off information.
    Reply With Quote Reply With Quote

  8. #8
    @drpainless1973 (quote somehow didnt work :O)
    i dont think its an upgrade, seems like the servers are just having problems, like other websites when they were overloaded or hacked
    Reply With Quote Reply With Quote

  9. #9
    Junior Member
    Join Date
    Mar 2010
    Posts
    2
    Same here! Fracked up website no pictures only red crosses.Login fail when using Uplay. Login fail when trieing to connect to patch server. Can't download new U-play launcher. Traced the signal and it fails somewhere in Montreal. This sucks!!!
    Last edited by brambo737; 07-13-2013 at 04:13 PM.
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •