Results 1 to 2 of 2

Thread: Can't reinstall Uplay | Forums

  1. #1

    Can't reinstall Uplay

    A little while ago, Uplay started buggering up (I don't remember what the problem was). After trying a few things, I decided to delete Uplay and reinstall it. Rather than using the uninstall option like I should have, I just went into my program files and deleted the Uplay folder (Uplay, Ubisoft Game Launcher, whatever it was called). But when I downloaded the installation file, it told me that "A more recent version of the application is already installed." So then I tried the uninstall option but that told me that it was already uninstalled. Then I tried using add/remove programs to get rid of Uplay, and it also told me that it was already uninstalled. Then I tried deleting every single file that had "uplay" in the name. Still couldn't reinstall. I even tried uninstalling my Uplay games from Steam. Still couldn't reinstall Uplay. The only option I can see now is to completely reformat my computer, but I don't want to do that.
    Is there any way that I can get Uplay back on my computer so I can play my few Ubisoft games again? Is there something, somewhere, that I have to delete or modify to fix this? Any help would be much appreciated.
    Reply With Quote Reply With Quote

  2. #2
    Moderator Ubi-Lhainiev's Avatar
    Join Date
    Jul 2012
    Location
    Ontario, Canada
    Posts
    2,001
    Hi Zombie - Can you give this a shot? (Reset Host files) http://support.microsoft.com/kb/9720...xItForMeAlways Then re-install Uplay from Uplay.com. Please tell me if it helps.
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •