Thread: Far Cry and Windows 8 | Forums

  1. #1

    Far Cry and Windows 8

    Hello,

    Ok, just got me a windows 8 64 bit. When I try and download Far Cry 1, I get a prompt saying ""Run setup32.exe on 32 bit Windows or run setup64.exe on 64 bit Windows!"

    Ok I'm not techy by any means, so can someone give me simple steps on how to fix this? (Where to go, what to download, where to download it, what destination file to download it too) so I can get this up and running? I mean simple instructions, I'm not a tech guru. Any help would be appreciated.

    Thanks,

    Rhino
    Share this post

  2. #2
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Location
    EMEA CRC
    Posts
    20,327
    Hi Rhino, please open a ticket with Technical Support, the link is in my signature.
    Share this post

  3. #3
    Cabster88's Avatar Junior Member
    Join Date
    Dec 2012
    Location
    Raleigh, NC
    Posts
    27
    Unfortunately, Far Cry is not supported on Windows 8. It is only supported on Windows 98SE/2000/XP (Only).

    I have included a link below to the game's minimum requirements:

    http://ubisoft.custhelp.com/app/answ...45/p/88%2C1086
    Share this post

  4. #4
    SF_Renegade's Avatar Far Cry 3 Elite Member
    Join Date
    Feb 2013
    Location
    DK
    Posts
    750
    On the net you can find some 64bit paches - I´ve run FC1 on win7 64 bit - so maybe if you install one of the patches it will run on win8

    http://www.moddb.com/games/far-cry/d...-cry-132-patch
    Share this post

  5. #5
    AlwaysHope's Avatar Member
    Join Date
    Feb 2013
    Location
    Tasmania
    Posts
    46
    Another way to put XP in Win 8 is via virtualization, I'm not up to speed on latest devs in 3D game performance in this area especially with regards to original FarCry, but they keep putting out new releases of platforms like "VirtualBox" might be worth researching..
    Share this post

  6. #6

    Installing Far Cry on Windows 8 64bit

    After some trial and error, I installed the first Far Cry game on Windows 8 64bit and it appears to work fine. After installing all the patches up to 1.4 the mouse did not work so i ended up uninstalling and did the following:

    - when installing do not select the option to install DirectX 9
    - once installed i then installed patch 1.1 and patch 1.3 only. I did not install the other patches which appear to be for 32bit versions and somone in another forum said not to install 1.33 and 1.4.
    - i then found the executable file, right clicked and in the properties option and selected the compatability tab. I then selecteds the option "run in compatability mode for XP".

    I then started the game and it has worked fine although i'm on level 2 so its possible there may be problems down the line. However the mouse works and graphics look good. Works for me.
    Share this post

  7. #7
    I run farcry on 8.1 fine. I had to use compatible mode tho or I got nothing.
    Share this post

  8. #8
    Originally Posted by Malpaso14 Go to original post
    After some trial and error, I installed the first Far Cry game on Windows 8 64bit and it appears to work fine. After installing all the patches up to 1.4 the mouse did not work so i ended up uninstalling and did the following:

    - when installing do not select the option to install DirectX 9
    - once installed i then installed patch 1.1 and patch 1.3 only. I did not install the other patches which appear to be for 32bit versions and somone in another forum said not to install 1.33 and 1.4.
    - i then found the executable file, right clicked and in the properties option and selected the compatibility tab. I then selected the option "run in compatibility mode for XP".

    I then started the game and it has worked fine although i'm on level 2 so its possible there may be problems down the line. However the mouse works and graphics look good. Works for me.
    I just built a new Windows 8.1 64-bit system and thought I would install Farcry (1) but cannot get past the 32 bit installer. I can run the installer under compatibility mode but when it starts it eventually fails because it is only a 32 bit installer. I have the original single disk version of FarCry and a later 5 disk version that I bought because I couldn't find my original disk case with the activation code.

    What I need to know is how to install a 32-bit game on a 64-bit system. Once it's installed I know how to run it under compatibility mode.
    Share this post