Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: "There is a patch for your game that is required to run it" | Forums

Far Cry Classic Launch Trailer [UK]

Far Cry 3 Blood Dragon - The year is 2007, it is the future

Far Cry 3 - Deluxe Bundle Trailer [UK]

Far Cry 3 Outpost App [UK]

  1. #1

    "There is a patch for your game that is required to run it"

    Keep getting this error while trying to play after the game patched to 1.05. It downloaded through the Uplay client and installed without an error, then this appears on boot. Clicking OK sends me to the patch webpage. I downloaded the exe file and ran that, it says it's installed after about a second and the same error appears on trying to launch.

    I'd rather avoid downloading the entire game again as my internet speed is pretty terrible and it would take days to do.

    Reply With Quote Reply With Quote

  2. #2
    Far Cry 3 Elite Member renegate47's Avatar
    Join Date
    Feb 2013
    Location
    DK
    Posts
    337
    I dl. this one - ran it and can play:

    http://static3.cdn.ubi.com/far_cry_3/farcry3_1.05.exe
    Reply With Quote Reply With Quote

  3. #3
    Quote Originally Posted by renegate47 View Post
    I dl. this one - ran it and can play:

    http://static3.cdn.ubi.com/far_cry_3/farcry3_1.05.exe
    Yep, same one I downloaded (twice, figured maybe the first was corrupted), no luck unfortunately. Thanks though.
    Reply With Quote Reply With Quote

  4. #4
    Resolved now, uninstalling and reinstalling Uplay fixed it (no extra patching necessary).

    EDIT- Scratch that, it fixed it for one load, now the problem is back...
    Last edited by bramblefeet; 03-04-2013 at 06:12 PM.
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    Feb 2013
    Posts
    1
    Same problem here.
    This error won't let me play.
    Reply With Quote Reply With Quote

  6. #6
    UK Forum Manager Ubi-Mush's Avatar
    Join Date
    Nov 2011
    Location
    E. Sussex, UK
    Posts
    15,878
    Hi guys, I suggest opening a ticket with Technical Support, the link is in my signature.

    I will also report it.
    Ubisoft UK Forum Manager

    Technical Support
    Twitter Support
    Facebook Support

    Reply With Quote Reply With Quote

  7. #7
    Junior Member
    Join Date
    Mar 2013
    Posts
    1

    Firewall Maybe?

    I have had a similar problem a couple of times with this sort of thing. Once with Steam and once with Uplay. After much head scratching it turned out to be Norton 360 firewall. I had to remove the program rules for both Steam and Uplay and then manually reset them. This then allowed both programs to start. Not saying this is your problem but it does seem that Norton doesn't always allow what it sees as a new program to access the internet.
    Reply With Quote Reply With Quote

  8. #8
    I have the same problem. My guess is that maybe I pressed quit too early while the updater was still active. It's kinda weird, after the patch is done installing, the updater stays there and does nothing, indicating that you can 'quit' it. Reinstalling the patch doesn't work, it seems to not do anything at all.

    I have also tried turning it off and on again (both uplay and my pc), no dice.

    EDIT: A word of warning: If you've turned off cloud saving and uninstall Uplay, your savegames will be gone for good, because they're in the uplay folder. Back them up beforehand!

    I've reinstalled uplay, and as bramblefeet says, it works once and the message shows up again afterwards. I was able to determine the patch status is still 1.04 when the game was running! So the update failed. But reinstalling the patch doesn't work either.
    Last edited by Orangenminze; 03-05-2013 at 12:11 AM.
    Reply With Quote Reply With Quote

  9. #9
    Community Manager MSV-Vextor's Avatar
    Join Date
    Aug 2012
    Location
    Malmö, Sweden
    Posts
    555
    Quote Originally Posted by Ubi-Mush View Post
    Hi guys, I suggest opening a ticket with Technical Support, the link is in my signature.

    I will also report it.
    I have to repeat what Ubi-Mush is saying. Here is the link: http://support.ubi.com/
    Reply With Quote Reply With Quote

  10. #10
    FIX: Uninstall game. Reinstall game. Let the updater update. DO NOT PRESS QUIT when the patches are done. The updater window has to vanish by itself.

    I did submit a ticket yesterday, will probably receive an answer in 3 days or so. Why are you guys so adamant about opening tickets? Will that change anything? Will that result in the devs recognizing that this problem exists because the Far Cry 3 Updater doesn't make it clear you're absolutely not supposed to click 'Quit'?
    Reply With Quote Reply With Quote

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •