1. #11
    I'm having a slight issue, when I try to start the game I just get this

    It worked 3 months back when I bought it...
    Share this post

  2. #12
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Location
    EMEA CRC
    Posts
    20,230
    Hi guys, please open a ticket with our Technical Support team, the link is in my signature.
    Share this post

  3. #13
    Originally Posted by Ubi-Mush Go to original post
    Hi guys, please open a ticket with our Technical Support team, the link is in my signature.

    Dude, can you please stop telling people to make a ticket for this issue - there is NO option for Driver in the technical ticket system.

    I've had this game for months and months and have never been able to play it since you updated it, its a joke, I think in total I've played it twice since release.
    Share this post

  4. #14
    there's problems with the game? Damn it,and i was thinking of buying it today
    Share this post

  5. #15
    HELP! I have a graphical error, The game openss just fine and thr opening cutscene is fine as well, but when I get into the game, all I get is black screen, the picture of tanner and his partner works and so does the mini map, but I cant drive!
    HELP!
    (BTW my graphics card is a mobility radeon X1600, which is supported, but its a laptop version so :P)
    Share this post

  6. #16
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Location
    EMEA CRC
    Posts
    20,230
    Hi, it could be because it is a laptop version, laptop versions may work but are not supported. I suggest opening a ticket with Technical Support so they can take a look at this for you, the link is in my signature.
    Share this post

  7. #17
    Yeah, I am having problems with this game as well.
    I bought the digital copy from Gamestop, and it asked me to download their Gamestop app to download the game.
    So I did and the game downloaded and everything seemed fine.
    So I go to play it, and it opens Uplay, and asks for the key, which I then input, and it accepts it.
    But, every-time I hit the play button, it does nothing. It just sits there.
    So I try to launch it from the Gamestop app, and the window then pops up, but i cannot play it still... is there an answer for this??
    Share this post

  8. #18
    Hi, my problem on the game is that when I click 'Play', the game appears to load the game, but after showing the synchronization screen on the monitor for a couple of seconds, the 'thank you for playing' screen shows, telling me that I have played the game for a total of 0 hours, 0 minutes. I feel that unless a problem is found on this matter, it will be £10 wasted on a game that will not even play on my computer. My system requirements are consistent with those recommended, and I have never experienced this sort of problem from downloading a Steam game, so I can only presume that somewhere along the way, the problems started with the U-Play servers, as perhaps it is something to do with the synchronization. If you could respond to my problem as soon as possible, it would be much appreciated.
    Share this post

  9. #19
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Location
    EMEA CRC
    Posts
    20,230
    Hi and welcome to the forums, please open a ticket with Technical Support, the link is in my signature.
    Share this post

  10. #20

    Game freezes hard when I go in Multiplayer

    I by this game when it came out (september 2011). Game works perfectly all this years. Two weeks ago I install Driver SF again to play online with my friends. 2-3 days it works fine but in one day, after couple of hours of play, I go to multiplayer and when lobby opens (camera go down to Tanner's Dodge Challenger) - game freezes hard and the only way to close the game - kill the driver.exe process in the Task Manager.
    My specs: AMD Athlon II X3 450 3.2 GHz, NVidia GeForce GTS 250, 4 Gb RAM.
    Share this post