Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: FarCry 3 SP Micro Lag | Forums

Map Editor | Far Cry 4 [UK]

Far Cry 4 | Kyrat Tuk Tuk Stories [EUROPE]

Far Cry® 4 Arena Master [UK]

CGI Launch Trailer | Far Cry 4 [PSN] [UK]

  1. #1

    Exclamation FarCry 3 SP Micro Lag

    I have this insane micro lag/stutter when playing the game.. low/medium/high/ultra dx9/11 are all the same. I got average 50fps on high and 1920x1080
    Also it seems like night time has more lag than daytime but both give me same fps. Please help...

    My PC:
    Phenom II 960t 3.0ghz
    Gigabyte gtx660ti 2gb latest beta drivers
    6gb ddr3
    win7 64bit
    Reply With Quote Reply With Quote

  2. #2
    Same problem..
    Reply With Quote Reply With Quote

  3. #3
    Junior Member
    Join Date
    Dec 2012
    Posts
    2
    I have the same problem too, seems to be quite a few posting on different websites about this problem.

    I had hoped to spend the weekend quietly playing Far cry but it runs so poorly on my system I havent played more than 20 minutes but spent about six hours troubleshooting.

    I7 3930K, HD6870x2, 16GB
    Reply With Quote Reply With Quote

  4. #4
    Yeah I got this too and have been reading various posts across the web about it. I have found that the best thing to do currently is to Force Adaptive V-sync in Nvidia CP (or AMD equiv) and turn off V-Sync in-game. Then, turn waterQuality down to High and Shadow Quality down to Medium - everything else on V high but not ultra. For Anti-aliasing, I use 2 in-game. Also, make sure if using Nvidia, use HBAO & AMD HDAO (or SSAO for less Quality for either). This seems to be the best performance settings (for Me) so far, but in one of the forums, a moderator mentions that he will get the dev team to look into it

    My Specs
    CPU - Intel Core i5 3570K (stock 3.4ghz / AC freezer 13 Fan)
    GPU - MSI GTX 670 (Power Edition)
    RAM - 8GB Cosair Vengeance LP
    Mobo - Asus P8Z77-V LE
    HDD - WD Caviar Black (640 GB)
    PSU - Corsair TX650
    OS - Windows 7 (64 Bit)
    Nvidia Driver - 310.64 Beta
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    May 2010
    Posts
    12
    Quote Originally Posted by moodonia View Post
    I have the same problem too, seems to be quite a few posting on different websites about this problem.

    I had hoped to spend the weekend quietly playing Far cry but it runs so poorly on my system I havent played more than 20 minutes but spent about six hours troubleshooting.

    I7 3930K, HD6870x2, 16GB
    I just tried forcing v-sync (and turning it off in-game) and it partially fixed the issue for me. You can still see it when driving, but hey this is better than it was before.

    I haven't tried lowering the graphics quality yet, so maybe that's why.

    Anyway, thanks for the help dude.
    Reply With Quote Reply With Quote

  6. #6
    With a little further tweaking, I have 99% eliminated my micro-stuttering. I have a 120HZ capable monitor, so I obviously have it at maximum all the time. I have V-sync forced as mentioned, but even though that is the case, my FPS still go over 60 in game because of my Monitor's 120HZ. I turned down my Refresh Rate to 60HZ. The game now locks its FPS at 60 and doesn't stutter no more. However, if the game goes below 60 / Refresh rate - stuttering occurs. But I have turned down enough in the settings, this only happens once in a blue moon.

    I would like to also mention other games with this problem - Assassin's Creed 3 & Splinter Cell Conviction (And just for the record, Conviction is still so bad, I cannot play it)

    I can see a pattern here ubi... I don't know though, maybe its a common issue with all these new 300 series Nvidia drivers and not Ubisofts fault. Although there would have to be an issue with the AMD drivers too... I will stop theorising who's to blame now.

    This issue (For ALL three games) needs to be addressed.
    Reply With Quote Reply With Quote

  7. #7
    Junior Member
    Join Date
    Dec 2012
    Posts
    5
    I had this problem - here is a short term solution until they fix the problem

    Go to documents/mygames/farcry3 and open up the gamer profile in notepad
    Right after showFPS="0" put maxFPS="30"

    it will lock your fps at 30 but no stutter...least its playable now..mine was not playable even at 50 FPS constant stutters..lame ubisoft..very lame
    Reply With Quote Reply With Quote

  8. #8
    still same prob, anyone have similar pc specs ive tryd all the above. i installed it on my SSDs hopin for a fix. no luck . any help appreciated thanks
    liquid cooled cpu 990x 4.5ghz and hd6990 @ 915 and 1430
    MB g1 killer
    RAM 12G gt dominator
    1200W antec HCP
    Reply With Quote Reply With Quote

  9. #9
    I found changing the below settings in Uplay gave a much more smoother and fluent movement in game, it really felt like a boost in fps, but they remain the same(using fraps). May not help in what you guys are getting but may help

    Note, uplay must be exited after making the changes



    I think its just the overlay that might be doing it, never messed around to find out what one it is(it could be offline mode too not sure). It does not change your fps, they will remain the same. So i think the overlay is screwing with something

    This changes your sp mode to offline mode too, worth testing to see anyway
    Last edited by Oceaniana; 12-03-2012 at 07:21 AM.
    Reply With Quote Reply With Quote

  10. #10
    on ultra my pc can easily I was really laughing when he lagt on far cry this simply can not bug or I do not know what I hope it fixed soon My spec


    Intel Core i7-3960X
    hard Drive
    3tb HDD 2 times 128 gb OCZ VTX4
    motherboard
    ASUS Rampge iv formula
    nutrition
    xfx 150W Black Edition
    memory
    corsair 16gb
    Graphics cards
    SAPPHIRE HD 7970
    cooling
    Corsair Cooling h100
    Reply With Quote Reply With Quote

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •