Results 1 to 7 of 7

Thread: Far Cry 3 crashes on start up. | Forums

Far Cry Classic Launch Trailer [UK]

Far Cry 3 Blood Dragon - The year is 2007, it is the future

Far Cry 3 - Deluxe Bundle Trailer [UK]

Far Cry 3 Outpost App [UK]

  1. #1

    Far Cry 3 crashes on start up.

    Whenever I start Far Cry 3, it will show me the "This game will save when this icon shows, do not turn off the power"
    And then after that it crashes.. "Far Cry 3 has stopped working." Any thoughts?? It does it every time..
    EDIT: Hmmm, disabling the Uplay In-Game Overlay seemed to fix it. But I'd rather have it enabled.. Anyone know how to get it running with the overlay enabled?
    Last edited by xDeadKiwix; 11-28-2012 at 10:27 PM.
    Reply With Quote Reply With Quote

  2. #2
    UK Forum Manager Mr_Shade's Avatar
    Join Date
    Nov 2009
    Location
    United Kingdom
    Posts
    18,869
    Is your uPlay upto date?

    The latest is 2.1.2 - please try exiting uplay and restarting it which should prompt the update if needed.

    if you are still having issues, please contact support.

    www.support.ubi.com
    Reply With Quote Reply With Quote

  3. #3
    Reply With Quote Reply With Quote

  4. #4
    Quote Originally Posted by Mr_Shade View Post
    Is your uPlay upto date?

    The latest is 2.1.2 - please try exiting uplay and restarting it which should prompt the update if needed.

    if you are still having issues, please contact support.

    www.support.ubi.com
    Yes it is.. The in-game overlay makes it crash for some reason, which is a shame.
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    Apr 2007
    Posts
    4
    I'm having the same problems.. All updated but 3 crashes so far in first 5 mins. And I always have to start all over again.
    Reply With Quote Reply With Quote

  6. #6
    Junior Member
    Join Date
    Apr 2007
    Posts
    4
    It seems to be fixed but I had to disable DX11, now I don't have the problems, but I want DX11... I have a 580 So it should handle it no worries.
    Reply With Quote Reply With Quote

  7. #7
    I think I actually found out why it crashes.

    DO THIS:

    1. Go into your NVidia Control Panel

    2. Click on the "Manage 3D Settings" Tab.

    3. MAKE SURE Anti-aliasing-FXAA is set to OFF!!!

    This is important as Far Cry 3 does NOT support FXAA.

    I was having crashes and getting nowhere with tech support. I finally found out that the cause of the problem is having FXAA set to "ON" because Far Cry 3 DOES NOT SUPPORT FXAA.

    Let me know if this works for your too.

    Thank you
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •