Results 1 to 3 of 3

Thread: Assassins Creed 3 (PS3) stuck at first loading screen. | Forums

The Assassin's Creed Experience - Comic-Con Day 3

Assassin?s Creed Unity Arno Master Assassin CG Trailer [US]

The Assassin's Creed Experience - Comic-Con Day 2

The Assassin's Creed Experience - Comic-Con Day 1

  1. #1
    Junior Member
    Join Date
    Nov 2012
    Posts
    1

    Assassins Creed 3 (PS3) stuck at first loading screen.

    Forgive me a similar thread has been posted before,

    I bought AC3 for PS3 the day it launched, played it a bunch, then set it down for a while. Maybe after a week or two of not playing it I tried to start the game, only to get stuck at the games first loading screen, after the eye safety/seizure warning screen. I've tried to search for people having the same problem, but so far no luck. To the best of my knowledge none of my save date has been messed with.

    I paid 60 dollars for this game, and now I can't play it. Needless to say I'm about to throw a fit of diva like proportions. Any help/advice would be greatly appreciated!
    Reply With Quote Reply With Quote

  2. #2

    Stuck in loading screen

    Hey,

    Try downloading the exlusive content in uplay.
    Then restart ps3, and try it again. For me that worked out happily caus im already on 50%
    Reply With Quote Reply With Quote

  3. #3
    I have the PS3 version and have run into the same problem further on into the game. The disc itself is in great condition. It has been 12 hours now of being stuck in a loading screen right after I pressed the button to 'start mission'. It is the Tulum memory. We are uninstalling the game and reinstalling it (you are able to do that without losing your saved data) to see if it will work. I will let you know how it works out. If anyone has any additional advice, I would greatly appreciate it.
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •