Results 1 to 5 of 5

Thread: Uplay won't launch AC3 | Forums

Assassin?s Creed Unity ? Wear the Phantom Blade Replica

Assassin?s Creed Unity Cast of Characters Trailer [US]

Assassin?s Creed Unity Story Trailer [US]

Assassin?s Creed Unity Experience #2 Customization & Co-op [US]

  1. #1

    Uplay won't launch AC3

    Alright, so I have tried everything I could think of to get this to work but to no avail. It is really annoying me.

    Here is what happens: I launch the game from steam, it opens Uplay, and shows the game. I hit play, and it tells me "Running Game..." After that, an "After Game Report. Thanks for playing!" shows up as if I had played the game. Nothing loads it just tries to run, then exits. Sometimes I get a "AC3SP.exe has stopped responding" error, but nothing more.

    I have tried just about all the solutions that would be relevant to this. I made sure all the important drivers have been installed and up to date, disabled Anti-Virus (MSE), launched Steam/Uplay/AC3 exe in Administrator mode, allowed the programs through the Firewall, reinstalled uplay, verified game cache, and reinstalled the game but to no progress. And yes, I have tried launching the .exe directly from the steam folder as well.

    I also want to mention the previous AC games have worked fine so far. AC3 is the only game giving me trouble.

    On the other hand, I bought AC3 on steam. So, I launch Uplay from there.

    Below are some system specs. Hope I included everything needed.

    Win 7 Pro 64 bit SP1
    RAM: 16GB
    Processor: Intel Core i5-2500K @ 3.30 GHz
    Video: Nvidia GeForce GTX 550 Ti
    Direct X Version : DX11
    Reply With Quote Reply With Quote

  2. #2
    Junior Member
    Join Date
    Sep 2012
    Posts
    2
    Well I have same type of problem. It say that I have cz version of assasin creed and when I press play it say running game but nothing happens. I played this game on few days ago and now it dont work.
    Reply With Quote Reply With Quote

  3. #3
    Junior Member
    Join Date
    Nov 2012
    Posts
    3

    Angry Uplay says Game Runing but nothing happens

    I press the button Play, then Uplay says Game Runing but nothing happens. No window opening. And the strange thing is that the .exe file is runing and when I stop the .exe it says I played for x minutes. How can I fix it? I unistalled the game and reinstalled it. But now when I start the launcher it ask the CD activation code a second time. In other words I have two Asassin'sCreed 3 in my Uplay then. It shows it 2 times. But the one isn't registrated. When I try to registre the second one it doesn't work because I already used the activation key. But at the same time when I start the one I registred it says Game Running but nothing happens. What should I do? Need help!!!
    Reply With Quote Reply With Quote

  4. #4
    Same here glad to know I am not the only one with this problem so Ubi can't ignore it forever
    Reply With Quote Reply With Quote

  5. #5
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •