Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: AC3 Frontiersman Quest - Unidentified Flying Object Glitch | Forums

Assassin's Creed Unity Make History Trailer [US]

Assassin?s Creed Unity ? Wear the Phantom Blade Replica

Assassin?s Creed Unity Cast of Characters Trailer [US]

Assassin?s Creed Unity Story Trailer [US]

  1. #1

    AC3 Frontiersman Quest - Unidentified Flying Object Glitch

    Everyone be warned. If you start a sidequest make sure you finish it before you turn the game off. I started the Frontiersman quest UFO in Boston and had to shut down my game. When i returned to play the clue markers were gone and now i am no longer able to do ANY frontiersman missions. It shows the map marker for the missions but when you enter the pubs you can do nothing but play the pub games. I've tried quitting and exiting the game through the menu, shutting down the xbox. I even did the next main storyline and it still wont work. Do i restart the game at 55% complete and forget those missions? Nope. What a pisser.
    Reply With Quote Reply With Quote

  2. #2
    Have you tried restarting the memory from the DNA tracker in the Animus?
    Reply With Quote Reply With Quote

  3. #3
    No i didnt see that option. I think you can only do that if your on a main story mission because it doesnt even show up on the menu screen.
    Reply With Quote Reply With Quote

  4. #4
    Junior Member KiriChan's Avatar
    Join Date
    Dec 2010
    Location
    Mordor
    Posts
    7
    I have the same issue.
    Nothing is true. Everything is permitted.
    Reply With Quote Reply With Quote

  5. #5

    Must be a glitch!

    I have spent a total of 38 hours so far playing this game and i am 84% complete, however for the Frontiersman Challenge solve the mystery of the UFO I believe this aspect to have a glitch. I know from posted videos the location of the UFO however it is not there, there are no clues and no green circle. I have spoken to everyone I believe to be frontiersman in Boston but still no luck. Anybody got any suggestions? I really need this to be resolved.
    Reply With Quote Reply With Quote

  6. #6
    The clues are on top of a tree for those who do not know. it's not located at ground level. If that doesn't solve your problem, I don't know what will but a patch.
    Reply With Quote Reply With Quote

  7. #7
    Community Manager Ubi-MoshiMoshi's Avatar
    Join Date
    Nov 2011
    Location
    CRC Newcastle-Upon-Tyne, UK
    Posts
    17,145
    Hi guys, please ensure you post this here http://forums.ubi.com/showthread.php...ible-Spoilers*
    Ubisoft Community Manager

    Technical Support
    Twitter Support
    Facebook Support

    Reply With Quote Reply With Quote

  8. #8
    I can't believe this still isn't fixed...
    Reply With Quote Reply With Quote

  9. #9
    Junior Member
    Join Date
    Mar 2011
    Posts
    4
    I am also having this issue. It is the only thing preventing me from getting 100% on the game. I logged a support ticket for it and they just sent me a canned response about fixing game freezing which has nothing to do with my issue.
    Reply With Quote Reply With Quote

  10. #10
    Looks like there won't be a patch for this anytime soon. Lots of threads on this bug, and no response from any ubisoft staff. Thanks Ubisoft.
    Reply With Quote Reply With Quote

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •