Results 1 to 7 of 7

Thread: "Insert Assassins Creed 3 Disc 2" | Forums

Assassin?s Creed Unity Co-Op Gameplay Trailer [US]

Assassin?s Creed Unity Co-op Heist Mission Commented Demo [US]

The Assassin's Creed Experience - Comic-Con Day 3

Assassin?s Creed Unity Arno Master Assassin CG Trailer [US]

  1. #1

    Exclamation "Insert Assassins Creed 3 Disc 2"

    I was playing Assassins Creed 3 just last night, and enjoying it i might add, though i thought it was time to hit the hey, so naturally I saved and quit. However, today i came home from school and felt i needed my hit of AC3 however when I insert disc 1, and go to my single player mission, as it loads it gives me a error saying "Please insert Assassins Creed 3 Disc 2". I know disc 2 is ONLY multiplayer and i wish to find out what is wrong so i can fix it ASAP.

    I had a look on various other forums and this has occured to others although they managed to fix it by restarting their consoles. I have tried, and failed this numerous times now and I don't know why this occurs. Any help would be great and as I said, I would like to fix this ASAP!
    Reply With Quote Reply With Quote

  2. #2
    Ubisoft Support Staff NCSA FredEx919's Avatar
    Join Date
    Oct 2008
    Posts
    1,189
    Hi, this is an issue with the way the XBL account interacts with the game. Try loading the game and then signing out of your Xbox live gamertag. This should take you to the main menu. You can then try signing back in at that point. If not, try signing out and then rebooting the Xbox and going into the game again. Either one of those should work.
    Reply With Quote Reply With Quote

  3. #3
    Thank You! This has fixed my problem and i am playing as we speak!
    Reply With Quote Reply With Quote

  4. #4
    I have a problem with my disc 2 every time I use it, it loads a bit and then freezes my xbox. the single player disc 1 works fine. can anyone help with this problem
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    Nov 2012
    Posts
    4
    Yeah, I am having the exact same problem. It goes up until it says "Checking Uplay Passport Status" and then it freezes every time. I have tried restarting the xbox, signed out and signed back in, and also tried to load from both discs' and still no solution.....
    Reply With Quote Reply With Quote

  6. #6
    Junior Member
    Join Date
    Nov 2012
    Posts
    1
    I am also having the same problem too. It goes till "Checking Uplay Passport Status" and then freezes. I went and got another disk 2 but it still freezes when loading multiplayer
    Reply With Quote Reply With Quote

  7. #7
    I have the exact same problem as the 3 previous people... I've never had it before, I played the Multiplayer 3 days ago alot and now suddenly it just freezes 7/10 times during "Checking Uplay Passport Status" and 3/10 times in the menu.

    It's not a problem with my 360, cause the SP works just fine and I don't think the disc is damaged or anything.. Would really like clarification from Ubi that this is some sort of Server overload?

    _____________________________________

    Since this seems to be a bigger problem I just made a thread about it, if some of you guys could go write some more info or any kind of updates in it? http://forums.ubi.com/showthread.php...-Freeze-Forums

    ...wanna play MP ;(
    Last edited by shiroshibal; 11-02-2012 at 11:04 PM.
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •