Page 75 of 168 FirstFirst ... 2565737475767785125 ... LastLast
Results 741 to 750 of 1671

Thread: Assassin's Creed 3: Single Player Bugs and Issues Thread *Possible Spoilers* | Forums

Assassin's Creed Unity Make History Trailer [US]

Assassin?s Creed Unity ? Wear the Phantom Blade Replica

Assassin?s Creed Unity Cast of Characters Trailer [US]

Assassin?s Creed Unity Story Trailer [US]

  1. #741
    If you haven't figured it out yet., update your system. Worked for me!
    Reply With Quote Reply With Quote

  2. #742
    Junior Member
    Join Date
    Nov 2012
    Posts
    4

    Twin Holsters/ Fast Travel bugs

    Twin holsters, when im using "pitcairn pistols", it's only giving me one "pistols" when I load another screen, forcing me to reequip them and when i do, same thing happens. I unlocked east countryside fast travel, and it doesn't show up on map. Viewpoints still left a boat load of black areas, like all west borders of each map. East countryside has none, and im still trying to find all liberation missions.

    This is on PS3
    Reply With Quote Reply With Quote

  3. #743
    Junior Member
    Join Date
    Nov 2012
    Posts
    1

    Third powersource.

    Not sure if this has been reported, but the stairs that you are supposed to take up to the third console that drop after putting in the second source are no longer accessible. It is as if they never dropped.
    Reply With Quote Reply With Quote

  4. #744
    1. I can connect to servers in game for pivots (sometimes, not always) but cannot connec to servers on multiplayer - limited mode keeps showing up, so far for a whole week when I tried access multi it never worked. Can't do the workaround as I don't have the option to log in either.

    2. Morris game with bartender is impossible to win - whenever I try to put a 3rd token in straight line the game doesn't let me, I can click on the space but nothign happens, Connor doesn't put the token on the spot which forces me to put it somewhere else which results in bartender owning me all the time as I am unable to make a straight line.

    3. After finishing game I understand Connor should be walking in his "side of the head shaved and war paint on" look? Well he doesn't his head looks like he had a lot of gel put on it and he always has his hood up.

    4. I did one delivery mission but when I check the progress it says 0%.

    5. I don't have any assassination targets on the map - it says I've done around 70% of the missions but no new targets are available.
    Reply With Quote Reply With Quote

  5. #745
    Already sent a message at ubisoft support since a few days now and didnt get any response, it still says unresolved though, anyway here are some bugs that really, really annoy me:

    1) I believe you must certaintly know about the twin holsters bug, in which when u fast travel suddently one of your pistols is changed for no reason and you got that anoying message that you have received a weapon

    2) After the Captain Kidd's missions i keep gettng a notification each time i fast travel or change location that i have received a shard of eden, everytime

    3) The citizen mission item acquired bug, finished game 100% still shows up when i fast travel or change location (sounds minor but its so annoying seeing 3 things everytime i fast travel A) 1 new pistol B) shard of eden C) Citizen bla bla Its really annoying have those 3

    4) Boston icon does not appear in the frontier map, i have been there so many times but it just shows up on my map whener it pleases
    Reply With Quote Reply With Quote

  6. #746
    I'm 99.94% complete 17060/17070 and cannot get 100%, its down to the fact one of my assassin recruits will not pass 90% (sworn in) despite having the points 1100/1100xp, on my ps3 "animus training center" stats they list 6 sworn in but online "assassins network" lists only 5, i already dealt with the Encyclopedia glitch.

    Any response would be appreciated after a five day wait for a patch that didn't help at all !!
    Last edited by MastaGengis; 11-23-2012 at 01:33 PM.
    Reply With Quote Reply With Quote

  7. #747
    I've played through Assassin's creed 3 and have encountered several issues. The Encyclopedia of the common man has glitched, attributing a task meant for the woodworker to the lumberers, now I am unable to complete his entry. I have attempted the mounted hunting task, but no matter what I try, it doesn't count. I am near to completing the Boston brawlers, but the icon marking the fights location is nowhere to be seen. I am also having difficulty completing the conversations with George Washington, I have gone past sequence nine already, could I go back to a mission in sequence nine and get those conversations? The progress tracker isn't indicating any completion for the delivery missions despite the fact that I have done several.
    Reply With Quote Reply With Quote

  8. #748
    Junior Member
    Join Date
    Nov 2012
    Posts
    1

    freezing in campaign?

    so i have had ac3 for about 2 weeks now and now it keeps freezing on me after about a minute of play. i have an xbox 360 arcade it isnt my system because all my other games work and i returned ac3 for a new copy because i thought it might have been the disc but the same thing happened so how do i fix this?
    Reply With Quote Reply With Quote

  9. #749
    1. there is NO QUIVER on alternate outfits, resulting in Connor magically pulling arrows out of nowhere.

    2. once a convoy has been attacked, it stays in the convoys list as *ATTACKED* and never disappears, even after crafting more convoys

    3. when using alternate outfits that have a hood in cutscenes, and connor takes off the hood in the cutscene, it shows him having SHORT BLACK HAIR.

    PLEASE FIX THESE BUGS!!!

    otherwise, awesome game
    Reply With Quote Reply With Quote

  10. #750
    Quote Originally Posted by TaleraRis View Post
    I'm having issues with the Frontiersmen Challenges 2. I cannot get the dive task to update. I've leaped from John's Town cliffs after looking up some advice on high enough places and it just won't click over for me.
    I'm also having this problem. I've done three or four dives off of that spot (including for the Optional Objective in the story) as well as from the top of a ship's mast in New York, but nothing has worked so far. >_>
    Reply With Quote Reply With Quote

Page 75 of 168 FirstFirst ... 2565737475767785125 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •