Results 1 to 9 of 9

Thread: Steam Install | Forums

Launch trailer - Might & Magic® X Legacy [UK]

Might & Magic X - Legacy - 4 New Classes Speed Painting trailer [UK]

Might and Magic X Legacy - The Gameplay trailer [UK]

Might & Magic X Legacy -- The Open Dev starts! [EUROPE]

  1. #1

    Steam Install

    Hey guys I don't know if this issue has been raised and wether it's down to steam only but i've recently bought the new DLC and was going to try the new content today but when i went to install the game i got this error "No steam content servers are currently configured to deliver content for this game. This will be corrected soon. Please try again in a few minutes.". To make sure this wasn't just an install problem I got one of my friends who already had it installed to try and launch the game through steam and he got the exact same error as me and there's quite a few complaints on the steam forum.

    So my question's are, have we got to wait for steam to sort this problem out? Is anyone who hasn't got steam having problems atm? Is there any chance that Ubi can poke the guys over at steam aswell to try and get this resolved ASAP as I've sent them a ticket but still no response.
    Reply With Quote Reply With Quote

  2. #2
    Senior Member
    Join Date
    Jan 2008
    Posts
    664
    I can confirm this issue. I'm currently putting it down to 'what else is new?'

    Still, this could be Steam's fault as well, so I'm just going to wait it out for now. Whichever side stuffed this one up - Lame.

    Oh well, guess i's back to waiting.
    Reply With Quote Reply With Quote

  3. #3
    As seen on http://forums.steampowered.com/forum....php?t=2908670, this is a rather widespread issue. Sadly, submitting a [steam support] ticket is the only thing possible.

    By the way, here is an answer:
    Hello,

    Thank you for contacting Steam Support.

    Thank you for taking the time to report this issue.

    We are aware of the problem and are investigating the issue further.
    Last edited by cossacking; 08-28-2012 at 08:44 PM. Reason: providing an answer from support
    Reply With Quote Reply With Quote

  4. #4
    A few minutes ago I got some patch:





    It's not patch 1.6 but probably something that solves the Steam issue so check if your Steam installation is working now.
    Reply With Quote Reply With Quote

  5. #5
    Yep, the game now launches.
    Last edited by cossacking; 08-29-2012 at 07:21 AM.
    Reply With Quote Reply With Quote

  6. #6
    Senior Member
    Join Date
    Jan 2008
    Posts
    664
    It now launches, aye, but sadly refuses to pick up on the fact that I've got the DLC. Did I miss anything?

    EDIT: Never mind, I could find it under "CD-Keys" in my game page on Steam.
    Reply With Quote Reply With Quote

  7. #7
    My game quit working completely around the time of this supposed Steam patch. It now crashes when I try to launch it.

    Does anyone know what this patch did? How can I tell if I got it. My version is 1.5.2.0.
    Reply With Quote Reply With Quote

  8. #8
    Quote Originally Posted by shop5F43AB863 View Post
    My game quit working completely around the time of this supposed Steam patch. It now crashes when I try to launch it.

    Does anyone know what this patch did? How can I tell if I got it. My version is 1.5.2.0.
    This is an undocumented ~188MiB patch that does not change the version number. You only know if you've seen Steam update MMH6 (look at downloads tab).

    Try restarting steam or changing the download region to force an update.
    Reply With Quote Reply With Quote

  9. #9
    Quote Originally Posted by cossacking View Post
    This is an undocumented ~188MiB patch that does not change the version number. You only know if you've seen Steam update MMH6 (look at downloads tab).

    Try restarting steam or changing the download region to force an update.
    I got the small patch last night. It did not change my problem (game won't launch and gives me a Windows crash error every time I try).

    As I said in another thread, since I've now tried reinstalling the game and Uplay to no avail, I'm starting to fear I may never get the game working again.
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •