i finally tried something new, creating a profile for the game exe in my manage 3d settings in the nvidia control panel.

i dont know exactly which setting of these fixed it, but my money is on the prerendered frames:

antialiasing FXAA - switched from ON to OFF

max prerendered frames - switched from 3 to 1

Vertical sync - switched from adaptive to OFF (not sure if this one really matters since i was only getting 50fps anyway in game, but tried it anyway)



with all these changed (doesnt have to be global setting just change it for the game exe only) my game no longer has mouse lag either in the menus or in the game