So I had that **** problem when I started my recently buyed game from steam Uplay opened and first of all appears the message Uplay.exe had stop working. So I closed it then started Uplay as administrator and the thing ran, then I started my game from Steam Uplay opened then Loading game information but ends with Unable to download game information.

Well first of all this is a Windows Problem not Ubisoft problem so blame Windows this time xD.

The problem is Windows don't let Uplay to be launch as administrator from steam so what you have to do is go to your Uplay install directory, then allow users (not only admins) to have a full access to the folder.

How to do this:
1.- Open Uplay folder (normally: C/Program Files/Ubisoft/Ubisoft Game Launcher
2.- Press right click
3.- Press Properties
4.- In Properties normally you start at General, switch to Security
5.- You'll see two screens, one with the users and system and creator owner and other with the permission for the users
6.- Click edit then it will open a new window
7.- At the upper screen select your user and at the window below you will see a lot of options checked and unchecked
8,- Check the option with name Total Control at the allow part then press apply
9.- Open Steam and launch your game again
10.- The game should load and then ask for your cd key, enter your cd key and play !

If this didn't work then maybe you should try this things that ubisoft support told me

Start by using the integrated steam tools to check the game files in case of any issues.

1. Right Click the game title from within your Steam game library

2. Choose Properties

3. Switch to the "Local Files" tab

4. Select "Verify Integrity of Game Cache"

5. Select "Defragment Cache Files"

6. If you still have trouble, delete the local game content and redownload.

Next, if you have already tried completely deleting your host files, please also use the steps listed within the Microsoft Support article in regards to actually resetting the files. This may be similar to deleting the host files, however the results end result could be slightly different.

http://support.microsoft.com/kb/972034


Finally, use the steps below to close any running background processes in case of issues with running programs

- Open your start menu and look for Run (Win XP), Start search (Win Vista), or Search programs and files (Win 7)
- Delete anything on the Open line that you'll find there, and type in the word MSCONFIG and press the Enter key to bring up the system configuration utility
- Look down the list of startup items (not the tab labeled Startup), and choose Selective Startup (if it is not already selected) (If you don't see this, make sure you've clicked on General, near the top of the window)
- Once you've chosen Selective Startup, uncheck 'Load Startup Items'
- Once you're done here, click Apply & OK, and let it reboot your computer

Try running the game again. If the game loads and seems to be working, the problem is most likely related to one or more programs you have scheduled to load with Windows. You can then revert the settings back the way they were, and in a trial and error fashion, disable some programs using the startup tab (in the msconfig utility) to try to find the culprit.

Or

Try configuring the following network ports in case the download issue is related to the a restriction on the network.

ACR Ports:
UDP: 21200, 7959, 3074

Uplay Launcher:
TCP: 80, 443, 13000, 13005, 13200

Im sorry for my bad english !