Results 1 to 10 of 10

Thread: Anno 2070 Connection Issues | Forums

  1. #1
    Junior Member
    Join Date
    Jul 2012
    Posts
    6

    Anno 2070 Connection Issues

    Bought this game on Friday via Steam. Installed it and went to run it but I just get an error message telling me "The connection to the server has been lost".

    This is extremely frustrating as I've been looking forward to playing this game since release. I've owned it for 3 days without being able to play it once!! No Anno forums either and it's almost impossible to find out anything constructive about why this is occurring.

    Am I ever likely to be able to play this game or should I be petitioning for a refund given that this game is currently unplayable?
    Reply With Quote Reply With Quote

  2. #2
    Yay same here mate \o/

    bought anno during the steam sale this week end, have never been able to play it. If this persists for the coming week I'm just gonna ask Valve for a refund and torrent it... I can't believe the amount of crap Ubi is throwing at its customer's face.
    Reply With Quote Reply With Quote

  3. #3
    Global Moderator Tully__'s Avatar
    Join Date
    Nov 2003
    Posts
    16,071
    There has been a server issue over the weekend that was preventing registration of new games and creation of new UPlay accounts. This issue should now be resolved. If you're still having issues, report them to Ubisoft support at http://support.ubi.com/en-GB/
    Reply With Quote Reply With Quote

  4. #4
    Already reported, they gave me an answer which doesn't help me play my game.

    Way to go Ubi, having your servers down during Steam sale week end /clap.
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    Jul 2012
    Posts
    6
    This issue is not resolved. Just tried to play Anno 2070 and, as before, the error message.

    Perhaps we could have a proper update?

    Cheers...
    Reply With Quote Reply With Quote

  6. #6
    Junior Member
    Join Date
    Jul 2012
    Posts
    6
    Quote Originally Posted by eclaireur90 View Post
    Already reported, they gave me an answer which doesn't help me play my game.

    Way to go Ubi, having your servers down during Steam sale week end /clap.
    Just checked my tech support request and got a similarly unhelpful response relating to UPlay, not Anno 2070. Will let you know if I make any progress...
    Reply With Quote Reply With Quote

  7. #7
    Junior Member
    Join Date
    Jul 2012
    Posts
    6
    Still not resolved. Tech support has been useless so far. Update please!!!
    Reply With Quote Reply With Quote

  8. #8
    ffs the game has been unplayable since the Steam sale and no update from Ubi, nothing!! I can't believe paying customers have to go through this while there are perfectly good and playable cracked versions out there. I know where I'll be getting my Ubi games from now!

    And btw it looks like Uplay is going to be around for a while: http://gamasutra.com/view/news/17443...sing_sales.php
    Reply With Quote Reply With Quote

  9. #9
    Junior Member
    Join Date
    Jul 2012
    Posts
    6
    Still not resolved... I'm a patient guy and understand there may be issues, but I'd love it someone actually TOLD ME WHAT THE **** THE PROBLEM IS!!!

    *deep breath*

    Please Ubi, do yourselves a favour and keep us in the loop.
    Reply With Quote Reply With Quote

  10. #10
    Community Manager Ubi-Mush's Avatar
    Join Date
    Nov 2011
    Location
    CRC Newcastle-Upon-Tyne, UK
    Posts
    16,682
    Hi, please see here http://forums-de.ubi.com/showthread....-has-been-lost you may want to try opening the ports.
    Ubisoft Community Manager

    Technical Support
    Twitter Support
    Facebook Support

    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •