Results 1 to 8 of 8

Thread: Uplay: GRRRRRRRRRRRRRR | Forums

  1. #1

    Uplay: GRRRRRRRRRRRRRR

    I got the game on the Steam special, setup my Uplay account and got playing, it was awesome! Managed to stop a huge tidal wave. Then when I tried to play today it didn't work. Uplay was refusing my login details. Fine. I asked to recover the password. You don't actually recover it, you give yourself a new one, which I did. Still couldn't login to Uplay. Then, with that Uplay account I succesfully logged a ticket this morning. Its about 8 hours later and still no response. I love that the account used for Uplay WORKS when you want to log a ticket, but not to actually play. Basically "bahahaha stuff you and your saved game, make a new one" which I refuse to do over fear of then getting used serial key/email already taken and other such stupid errors. I will wait for this ticket to be solved and I will post an update every day to remind them that I cannot play the game.

    Instead of trying to reinvent the wheel why don't people try emulate Steams success.... *sigh*
    Reply With Quote Reply With Quote

  2. #2
    Junior Member
    Join Date
    Jul 2012
    Posts
    1
    I'm having the same problem except I didn't start playing to day, which means that I can't play at all. I already have an account, so I tried making a new one. I keep getting an error that the ubisoft servers are unavailable. I would be able to play in the offline mode, but you HAVE to log in at least once.

    I don't mind DRM, but if you're going to use it, you should GUARANTEE that your DRM servers are up at all times. It really is annoying to people who buy something yet can't use it.
    Reply With Quote Reply With Quote

  3. #3
    Junior Member
    Join Date
    Jul 2012
    Posts
    5
    I'm having the same problem. I recovered my password, made a new one and now I can't login.
    Reply With Quote Reply With Quote

  4. #4
    Junior Member
    Join Date
    Jul 2012
    Posts
    1
    I am having the same problem, They have been having problems like this for at least a year:
    http://forums.steampowered.com/forum....php?t=2147696
    http://www.gamespot.com/assassins-cr...down-61891047/
    When is Ubisoft going to get their **** together!?!
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    Jul 2012
    Posts
    2
    I'm having this problem, except I haven't even gotten to play the game yet. I bought it from steam and tried to sign up for uplay. Can't register because the servers are unavailable. Okay. Go to ubisoft website and make one there instead! Go back over to it, refuses login information.
    Reply With Quote Reply With Quote

  6. #6
    Junior Member
    Join Date
    Jul 2012
    Posts
    1
    it's an outrage. we aren't just force to use that piece of **** called 'uplay"; no it just doesn't work. well from dust is my last ubisoft game, that's for sure!
    Reply With Quote Reply With Quote

  7. #7
    YEs and ive had this game for a year and its asking for the Auth Key to play i just played this game last Monday WTF
    Reply With Quote Reply With Quote

  8. #8
    ***All fixed
    Last edited by DogS0ldier; 07-16-2012 at 05:05 PM.
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •