Results 1 to 8 of 8

Thread: From dust crash | Forums

  1. #1

    Unhappy From dust crash

    So a friend gifted me from dust The problem is that when i open it.It shows the intro then it says loading and after a 20 seconds or something a black screen appear and it crash.I got an ati radeon hd 3600 series video card.(Not sure if you wanna know that)Is there a way to fix it? iam sorry if this is the wrong air to post it iam new to this forum

  2. #2
    Well.... I dont know how good that card is, are you using a laptop? mabye the game exploded on you because your using a laptop?
    on a more real note, I dont know as I dont have these issues, Could you please post the rest of your specs like graphics card, laptop or desktop, ram, and cores?

    And good luck getting this fixed....

    **EDIT** also as of a few mins ago the servers are having issues, mabye try when they are back up?
    Got a steam account..?? Feel free to post your name or nickname here and ill add you and let you know when its up

  3. #3
    I have got windows xp and iam on a pc not laptop.I also have 2 gb of ram an ati radeon hd 3600 series video card and as for my cores iam not sure how to find it :3

    EDIT: i had the same problem before servers problem.

  4. #4
    Try not playing in full screen.

  5. #5
    I have the same problem. And I don't know how to change the settings to not play in full screen.

  6. #6
    I cant even go to the menu it crash after the loading screen (after the intro)

  7. #7
    I I have windows 7 64-bit and I am experiencing the same problem. The game crashes after the ubisoft intro animation.

  8. #8
    Community Representative Ubi-MoshiMoshi's Avatar
    Join Date
    Nov 2011
    Last edited by Ubi-Mush; 11-17-2012 at 02:19 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts