Page 4 of 4 FirstFirst ... 234
Results 31 to 32 of 32

Thread: Are you kidding me, these servers suck. | Forums

  1. #31
    Bumping old thread to say that it's 2013, and these problems are even worse. I've been trying to activate my Uplay passport but the servers are always having issues. I've gotten on maybe twice when I first got the game and it was fun, but I figured I would play some then activate later, afterall my passport code isn't going anywhere. Well I havent been able to connect since. Ubisoft servers are always "unable to connect" even when I "try again later". It's gotten to the point where I can only access Kenways fleet 50% of the time.
    It's literally ruined the game for me and I wish I hadn't spent money on the season pass because it's not like I can ever use any of the dlc. I haaate ubisoft.
    Reply With Quote Reply With Quote

  2. #32
    Member
    Join Date
    Jul 2008
    Location
    England
    Posts
    44
    hate is such a strong word the guys on the forums do try to help not sure about support they try to blame every body but the servers but even support have to toe the line and do as they are told I have played the beta and had the game since day one the lag has got worse as time has gone on. the other night got disconnected 10 times in 15mins and the Ubisoft service is not available at this time. Please try again later. I get this some days but not others and I am actually thinking about stopping playing this game as I have had enough. I have played Splinter Cell Black List and Assassins Creed and they don't seem to suffer from this problem maybe a bit of lag. I have contacted support on all the problems but no joy I do like ghost recon
    Reply With Quote Reply With Quote

Page 4 of 4 FirstFirst ... 234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •