Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 46

Thread: Ubisoft Game Launcher Download | Forums

Assassin?s Creed Unity Season Pass Trailer [US]

Assassin?s Creed Unity Co-Op Gameplay Trailer [US]

Assassin?s Creed Unity Co-op Heist Mission Commented Demo [US]

The Assassin's Creed Experience - Comic-Con Day 3

  1. #11
    Junior Member
    Join Date
    Nov 2012
    Posts
    1
    shut up....
    Reply With Quote Reply With Quote

  2. #12
    ...now what i do to u?
    Reply With Quote Reply With Quote

  3. #13
    i want to get assassin creed revoluation game launcher
    Reply With Quote Reply With Quote

  4. #14
    Senior Member
    Join Date
    Mar 2011
    Posts
    943
    It is now called uplay, go to uplay.com and download installer.
    Are you facing some problems in assassin's creed revelations? Check this faq, maybe there is a solution:
    http://forums.ubi.com/showthread.php...nity-based-faq
    And here fo Assassin's Creed III game:
    http://forums.ubi.com/showthread.php...ns-to-problems
    Black Flag:
    http://forums.ubi.com/showthread.php...99#post9515499
    Interesting blog i've found some time ago:
    http://themaningrayhat.wordpress.com/

    "Devs are aware"!!!!
    Reply With Quote Reply With Quote

  5. #15
    Quote Originally Posted by Ubi-Mush View Post
    For problems with the launcher please try this;

    To resolve this issue, you will need to manually install or reinstall the GameLauncher software, which handles the online authentication in the game. Please note that this software MUST be installed to play the game, and cannot be uninstalled or disabled.

    1. First, you will need to uninstall the "Ubisoft Game Launcher" software from the 'Add/Remove Programs' (Windows XP) / 'Installed Programs' (Windows Vista and 7) icon in your computer's control panel. It's possible that the "Ubisoft Game Launcher" software will not be listed if you have already uninstalled it, or the game. If so, you can skip this step.

    2. After uninstalling the software, you will need to manually delete any leftover files in the C:\Program Files\Ubisoft\Ubisoft Game Launcher (32-bit versions of Windows) or C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher (64-bit versions of Windows). Please do not skip this step, it is very important. If this folder does not exist, please go to the next step.

    3. Reinstall the GameLauncher software from: http://static3.cdn.ubi.com/orbit/lau...rInstaller.exe.

    And what do you do if the launcher tells you that there is already a previous version installed even though this is a brand new computer that never touched an Ubisoft game? And it seems that all of the solutions that I'm able to find are if it was purchased though Ubi directly. How about those people who baught it on Steam? I followed the instructions that they gave to go in and install the program file they have in there, but that installer doesn't even run. So perhaps you should try making us a ZIP file so we don't have to deal with your installers since they are broken.
    Reply With Quote Reply With Quote

  6. #16

    Exclamation Ubisoft Game Launcher Download Link not reachable from Germany

    Quote Originally Posted by SJFERGY18 View Post
    I've been having trouble playing assassin's creed 2 downloaded through steam. I found this link: http://static3.cdn.ubi.com/orbit/lau...rInstaller.exe which was supposed to allow me to install the game launcher properly, but when I go to this link it says "oops! page not found" and nothing else happens. I've tried disabling my antivirus and firewall and still can't download this. Help would be appreciated.
    Hi, i had the same issue that the Download Link didn't work. This seams to be a regional Problem. I'm located in Germany. I tried to access the Link through a Chinese Proxy Server (which hides my original location and tells the Ubisoft Server I'm comming from China instead of germany) and it worked fine.

    You can find a List of Public Proxy Servers:
    http://www.hidemyass.com/proxy-list/

    How to set up the proxy settings in your Web browser:
    for Google Chrome:
    http://www.googlechrometutorial.com/...-settings.html

    or just google for "Proxy configuration firefox" etc..

    hope this helps someone
    Reply With Quote Reply With Quote

  7. #17
    Junior Member
    Join Date
    Jan 2013
    Posts
    1
    To fix the error with steam its simple
    Go to the Ubisoft folder and unistall de Ubisoft after do it
    Download the Ubisoft game launcher rlstaller.exe
    and wait the update after the update log in and play
    Reply With Quote Reply With Quote

  8. #18
    I got no ubisoft folder in my C:\Program Files (x86) and it when i try to install the game launcher for assassin's creed 2 it said uplay was already installed, im so pissed
    Reply With Quote Reply With Quote

  9. #19
    Community Manager Ubi-Mush's Avatar
    Join Date
    Nov 2011
    Location
    E. Sussex, UK
    Posts
    16,255
    Ubisoft Community Manager

    Technical Support
    Twitter Support
    Facebook Support

    Reply With Quote Reply With Quote

  10. #20

    launcher problems

    ive deleted every single info on the UBISOFT and it still says that i have it installed!!!

    i have tried that website that was posted!!!
    I thiought getting a new game would solve the problem, I was wrong, still the same thing!!!!!!!!!
    whats wrong with this thing?????????

    anyone have a diff opinion besides the ones that have been given ???
    thanks
    Reply With Quote Reply With Quote

Page 2 of 5 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •