Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: ACRSP.exe Stopped Working | Forums

Assassin's Creed Unity Revolution Gameplay Trailer [US]

Assassin's Creed Unity Official E3 2014 Co-op Commented Demo [US]

Assassin's Creed Unity: Introduction to Arno [US]

Assassin's Creed Unity E3 2014 World Premiere Cinematic Trailer [US]

  1. #1

    ACRSP.exe Stopped Working

    Ok, here I am again trying to search for help in the Ubisoft forums. About 3 weeks ago I started to have a problem with ACR via Steam: everytime that I clicked the Play button on the Ubisoft Launcher, the game goes to a black screen, just like it would start the game normally, but then White Screen and Error Message "ACRSP.exe has stopped working" I search on both forums, Steam and Ubisoft Forums, and I found no usefull help.

    As always I found generic "helpfull" troubleshooters, like "tried to update your video card?" or "Do your PC matches with the game requirements?" You see, I already tried everything about that... Checked Cache Integrity, uninstall and re-install the game, punkbuster update, tried to start on offline mode, uninstall and re-install the ubisoft launcher, re-update the game to the latest version (1.03), update drivers and stuff... But none of that worked... Please I am really confused about all that, every other Ubisoft Game works fine, just that Revelations Thing that is making my head aches...

    And please before any one asks yes my pc matches with the game requirements, yes I have the latest drivers and yes I played before the crash (I have 112h played on Revelations) so please! NO GENERIC ANWSERS!

    Appreciated...
    Reply With Quote Reply With Quote

  2. #2
    Junior Member
    Join Date
    May 2012
    Posts
    2
    I also have the same error message
    when i start the game the ubisoft logo comes and then a text (this work of fiction is created developed by various religious....)
    and then the game crashes saying acrsp.exehas stopped working!
    I have dell alienware m17x which i buyed in december and i do not think that my hardware is the problem!
    Also i have vista business 32 bit
    please ubisoft and friends help me - i really want to play this game!
    Tried using the skidrow ofline crack but still the same error- plz help me
    Reply With Quote Reply With Quote

  3. #3
    Quote Originally Posted by Adarsh100 View Post
    I also have the same error message
    when i start the game the ubisoft logo comes and then a text (this work of fiction is created developed by various religious....)
    and then the game crashes saying acrsp.exehas stopped working!
    I have dell alienware m17x which i buyed in december and i do not think that my hardware is the problem!
    Also i have vista business 32 bit
    please ubisoft and friends help me - i really want to play this game!
    Tried using the skidrow ofline crack but still the same error- plz help me
    Yeah, I know your feelling... You see, my ACR don't even bother to show that Logo, it just crashes when it starts the game...
    Trying here to Up de Thread, because it seens like no one wants to help... Please someone help...
    Reply With Quote Reply With Quote

  4. #4
    Junior Member
    Join Date
    May 2012
    Posts
    2
    Yeah I've had the same problem since back in January. 100+ hours of game time and then suddenly it stops working. If I run singleplayer it crashes immediately. If I run multiplayer it goes to the abstergo loading screen then crashes. I went through Ubisoft tech support and went back and forth for about 10 days with them getting half-assed solution suggestions before giving up. Still haven't been able to fix it. Every now and then I google the problem to see if a fix has come up but find nothing. I think at this point they aren't really interested in putting any serious resources into finding the source of this problem. It's sad though because it seems like a lot of people have it.
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    May 2012
    Posts
    2
    i've been thinking!!!!! i think there's a problem with our game. (though i buyed the original one)
    also for your information guys ubisoft games are known only for their GLICHES nothing more.
    because of releasing asassins creed games annually- the games lack programming. and if there would be a solution then ubi. would have told the actual reason and the solution.
    I think the problem could't be resolved! i'm contacting them and ther are saying - 1. try to update your drivers
    2.try to close all the background apps. .......
    I GUESS AC 3 WILL BE GOOD.
    Reply With Quote Reply With Quote

  6. #6
    UK Forum Manager Ubi-Mush's Avatar
    Join Date
    Nov 2011
    Location
    E. Sussex, UK
    Posts
    15,865
    Hi guys, have you contacted technical support? the link is in my signature.
    Ubisoft UK Forum Manager

    Technical Support
    Twitter Support
    Facebook Support

    Reply With Quote Reply With Quote

  7. #7
    Yes we Did Mush.... And again, once more, no Workfull Help that fix the issues...
    Reply With Quote Reply With Quote

  8. #8
    Ok, so here is something that I just tried and really made me look foward, it isn't a fix, but the cause of the problem!
    I'm was in my friend's house, and tried to play ACR in his computer. I tried to logged in with my account, and guess what? THE GAME DIDN'T STARTED ACRSP.EXE CRASHED! Yes, I showed him and tried to logged in with his account (ask him to do it) he put his loggin and password, and guess what? THE GAME STARTED! So, what I think it's happening is some kind of problem on Ubisoft server on the clouded saved games... Is there someway to deactivated (I use steam). So I will send a ticket to Ubisoft about that, and also I will try to deactivate the Steam Clouded Saves and Ubisoft Synchronization Saves


    EDIT: Well, I send Ubisoft a ticket about my problem, and once again they seen to lack in support. They send me a response that has nothing to do with my problem, about my video card updates and sound card updates, when my ticket was about my problem in start the game even on computers that the game runs fine. I tried the clouded saved games deactivation manually, didn't work (even on steam and Uplay). I send them another ticket, being pretty much Clear about my problem, and hope that they actually read the **** ticket and do not send me a "copy & paste response"
    Last edited by GiovanneRico; 06-12-2012 at 04:48 PM.
    Reply With Quote Reply With Quote

  9. #9
    Junior Member
    Join Date
    May 2012
    Posts
    2
    Quote Originally Posted by GiovanneRico View Post
    Ok, so here is something that I just tried and really made me look foward, it isn't a fix, but the cause of the problem!
    I'm was in my friend's house, and tried to play ACR in his computer. I tried to logged in with my account, and guess what? THE GAME DIDN'T STARTED ACRSP.EXE CRASHED! Yes, I showed him and tried to logged in with his account (ask him to do it) he put his loggin and password, and guess what? THE GAME STARTED! So, what I think it's happening is some kind of problem on Ubisoft server on the clouded saved games... Is there someway to deactivated (I use steam). So I will send a ticket to Ubisoft about that, and also I will try to deactivate the Steam Clouded Saves and Ubisoft Synchronization Saves


    EDIT: Well, I send Ubisoft a ticket about my problem, and once again they seen to lack in support. They send me a response that has nothing to do with my problem, about my video card updates and sound card updates, when my ticket was about my problem in start the game even on computers that the game runs fine. I tried the clouded saved games deactivation manually, didn't work (even on steam and Uplay). I send them another ticket, being pretty much Clear about my problem, and hope that they actually read the **** ticket and do not send me a "copy & paste response"
    That's really interesting. I hope someone sees this and gives a ****.
    Reply With Quote Reply With Quote

  10. #10
    Same problem (or similar)....i was playing through Capadocia and after i murdered the dude who was torturing the prisoners, the game crashes....no problem, not the first time it did that, i'll restart and load my position, do it again....WRONG!!! Every time i try to load, as soon as the scene is supposed to start (it doesnt get to come on screen), it crashes again....and again....and again. I cant resume the game...
    I dont know if i can start at another save point because the f***** uplay only gives me the one save to load...and it goes to the same spot, same result....anyone had that problem or has any idea how i can fix this???
    Reply With Quote Reply With Quote

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •