Results 1 to 7 of 7

Thread: POP:TFS - Game lags suddenly in progress at regular intervals after playing on Uplay | Forums

  1. #1

    POP:TFS - Game lags suddenly in progress at regular intervals after playing on Uplay

    I had played the game without registering previously using skidrow as I didn't have an internet connection at home. Now that I have one, I registered with Uplay and started playing online. Game just freezes up and starts lagging like hell at regular intervals. Then gets sorted again and vice versa. It's been frustrating. I have changed graphic settings to medium and still the same ****. I have played at higher settings with skidrow and never had any lags before. I have played Serious Sam games at high res on steam online without issues so this particular issue is frustrating me. I have a NVidia GTX8600 card which is sufficient for POP with 3 gb ram on core2duo, Win7Ultimate.

    Is this because of playing online? if so the Uplay system is very poor compared to Steam. I might just chuck it if this continues. Anyone else having same issues despite a good system? Could NVidia updated drivers cause it?
    Last edited by SeriousPrince; 04-30-2012 at 04:16 PM.
     

  2. #2
    Community Representative Ubi-MoshiMoshi's Avatar
    Join Date
    Nov 2011
    Location
    EMEA CRC
    Posts
    19,908
    Hi, have you contacted technical support? the link is in my signature.
     

  3. #3
    No. I wanted to see if similar issues have been reported. I will re-install and try again. If it persists customer support might be an option. To be honest I didn't get a good co-operation with support when I reported a defective Will Rock CD. It wouldn't accept valid installation key and I had to use a no CD crack finally. I mailed my CD barcode, license key and other details with scanned jpegs in correspondence but never got help for replacing that one so I haven't much hope here as well. I haven't had the same issues with other 4 POP games before.
     

  4. #4
    Suppose I uninstall and re-install game. Will I need to re-register uplay? Or will it automatically take me in on existing login? Does uplay allow registration only once?
     

  5. #5
    Community Representative Ubi-MoshiMoshi's Avatar
    Join Date
    Nov 2011
    Location
    EMEA CRC
    Posts
    19,908
    If you re-install you should be able to just login with the Uplay account details which you used to install it originally.
     

  6. #6
    Can't play the game for an hour now as it 'attempts to establish network connection'. Rest of internet is working just fine so another reason why playing online sucks. Now the **** thing lags even at lower graphic settings. Strange indeed. Guess I will have to re-install. But this network glitches are real letdown as well.
     

  7. #7
    Community Representative Ubi-MoshiMoshi's Avatar
    Join Date
    Nov 2011
    Location
    EMEA CRC
    Posts
    19,908
    Your best bet is to contact technical support as they will be able to troubleshoot with you.
     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •