Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Prince Of Persia Warrior Within Crashes When I load The Game | Forums

  1. #11
    Quote Originally Posted by YAZ_H View Post
    the game is old enough to meet the specs of his computer, ok you need to disable all graphics options and run the game on basic settings, then start enabling settings one by one until you find the faulty option. but still cannot understand why it crashes on loading saves but runs ok when starting new game. usually crashes on loading are related to RAM, so i was suspecting the virtual memory, but from the log , he has 2 GB available.

    i tried this and didnt work too

    come on guys give me a solution
    Reply With Quote Reply With Quote

  2. #12
    Quote Originally Posted by Pa3PyX View Post
    I'm more puzzled by the fact it's an FPU exception... unlike CPU exceptions, these are normally always off unless the application or driver library specifically turns them on (_controlfp() call, or setting FPU control word directly?). Which makes me suspect debug builds of drivers.

    Had one more idea meanwhile -- maybe setting prerender limit to 0 in graphics control options would fix it, if it is indeed a frame timing issue.
    how can i do that?
    Reply With Quote Reply With Quote

  3. #13
    Quote Originally Posted by AhmadShehadhe View Post
    how can i do that?
    Right-click empty space on desktop, select NVIDIA Control Panel, then Manage 3D Settings, then (on the right) set "Maximum pre-rendered frames" to 1 and hit Apply.

    The control panel will also tell you the video driver version you have (at the bottom, hit System Information, then look at ForceWare Version in the Display tab). If it's less than 175.19, you'd do well to upgrade (download and install from nVidia site). If it's higher than that, it's probably an unstable/debug/beta release and you'd do well to downgrade.

    BTW if NVIDIA control panel is missing (you do not see that option on the desktop right-click menu), it's probably a default Windows driver for the video board and you definitely need to upgrade.
    Reply With Quote Reply With Quote

  4. #14
    Quote Originally Posted by Pa3PyX View Post
    Right-click empty space on desktop, select NVIDIA Control Panel, then Manage 3D Settings, then (on the right) set "Maximum pre-rendered frames" to 1 and hit Apply.

    The control panel will also tell you the video driver version you have (at the bottom, hit System Information, then look at ForceWare Version in the Display tab). If it's less than 175.19, you'd do well to upgrade (download and install from nVidia site). If it's higher than that, it's probably an unstable/debug/beta release and you'd do well to downgrade.

    BTW if NVIDIA control panel is missing (you do not see that option on the desktop right-click menu), it's probably a default Windows driver for the video board and you definitely need to upgrade.
    didnt WORK
    Reply With Quote Reply With Quote

  5. #15
    Quote Originally Posted by AhmadShehadhe View Post
    didnt WORK
    Then short of trying different driver versions in the hopes of finding one that works, I'm out of ideas. And I can't even be sure the crash is related to that. Can't help you if I can't reproduce the problem, and I can't (though I've been playing with 175.19 drivers, at different points in time, on both GeForce FX 5700 Ultra and GeForce 7950 GT).

    The only things I can think of would be tweaking BIOS settings like AGP Fast Writes, AGP Side Band Addressing, AGP Rate, AGP Aperture Size... or installing RivaTuner to tweak these (and more) at the driver level to try and achieve stability. But if you're not familiar with these settings, at this point you'd probably be investing more time in this old computer than you'd want to.
    Last edited by Pa3PyX; 05-06-2012 at 12:48 AM.
    Reply With Quote Reply With Quote

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •