Results 1 to 3 of 3

Thread: Uplay not working... | Forums

  1. #1

    Uplay not working...

    i tried to sign into it on splinter cell conviction, and it kept saying the servers are down.
    i put in my assassins creed game and it worked fine. bot in brotherhood and revelations.
    why does stuff like this happen, i pre-ordered SC:C and had to wait two whole years for this beta, and when it gets here you guys screw me out of it.





    you are really starting to disappoint me on a daily basis Ubisoft. Get your heads in the game.
    Reply With Quote Reply With Quote

  2. #2
    UK Forum Manager Ubi-Mush's Avatar
    Join Date
    Nov 2011
    Location
    E. Sussex, UK
    Posts
    16,170
    Hi, have you contacted Technical Support? you can do so by clicking on the link in my signature.
    Ubisoft UK Forum Manager

    Technical Support
    Twitter Support
    Facebook Support

    Reply With Quote Reply With Quote

  3. #3
    Junior Member
    Join Date
    Jul 2012
    Posts
    3
    Technical support? come on, is the **** fault of Ubisoft, they do all wrong lately, Everything, all the games released with tons of bugs, unplayable and now this, they release Uplay which these stupid bugs instead of releasing it once it works fine
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •