Results 1 to 2 of 2

Thread: Multiple problems with HoMM V & expansions | Forums

  1. #1
    Member daydr3am3r1987's Avatar
    Join Date
    Jun 2008
    Bucharest, Romania

    Multiple problems with HoMM V & expansions

    A few years ago I bought Heroes Of Might And Magic Complete Collection (the one in the big white box). I played the game since then on a regular basis and kept the game installed. However, a few months ago I had to uninstall all HoMM V games to free up some space (to install HoMM VI). This was also my first time uninstalling HoMM V since I usually reinstall Windows without uninstalling to many apps before (unless I have to save my license key & registration). At that time I was running Windows 7 Professional x64, all updates installed. The uninstalling process took less than 5 seconds and that seamed really weird. Right now I tried to reinstall HoMM V but it said it is already installed. I manually looked for related reg keys and deleted 'em all and managed to install all 3 games. However, after installation process ended (after pressing Finish ****on), instead of closing InstallShield, the process hanged and after 20 minutes of waiting I stopped the process. This happened with all 3 games. Also, this happened before, right after switching from XP x86 to 7 x64. After I installed the games I tried updating HoMM V (1.5 installed) and Tribes of the East (3.0 installed). The AutoUpdater utility downloaded the patc, the setup file and (technically) updated the game. However, the H5_Game.exe file remained the same and the game version, as it is displayed in the game menu screen, remained unchanged(1.50 & 3.0). I tried updating the game again but the updater says the game is already up to date. I also downloaded the patches manually (EU version) and tried updating manually but again, the setup says the game is already up to date. Any ideas on how to fix this? I searched on many forums & websites, including celestialheaven, nothing helps.

  2. #2
    Community Representative Ubi-MoshiMoshi's Avatar
    Join Date
    Nov 2011
    Hi, as you have tried the things I was going to suggest your best bet is to contact technical support, you can do that by clicking on the link in my signature. They will be able to troubleshoot with you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts