Results 1 to 3 of 3

Thread: Possible glitch? | Forums

Far Cry Classic Launch Trailer [UK]

Far Cry 3 Blood Dragon Walkthrough Trailer [US]

Far Cry 3 Blood Dragon - The year is 2007, it is the future

Far Cry 3 - Deluxe Bundle Trailer [UK]

  1. #1
    At the end of Boat, after shooting down Crow, I'm instructed to collect a PDA. I'm told that I'm going to be picked up, and I see the boat coming forward. It stops infront of the sunken ship, and Doyle stops talking. I can't figure out what to do, am I so supposed to go somewhere? The last objective is to go to the front of the ship, but after trying that I still get the same result. Killing everyone before the boss still had the same effect, what am I missing?
    Reply With Quote Reply With Quote

  2. #2
    you are doing nothing wrong, that should be the end of the level, try reinstalling the game.
    My spec:

    Dell Dimension 2350

    512mb RAM
    P4 2.0ghz
    nvidia geforce fx 5200 128mb

    3d Mark 2001 score: 3965

    3d Mark 2003 score: 768
    Reply With Quote Reply With Quote

  3. #3
    That is the end of the level, the script should start and no matter where you are the boat should "pick" you up when it stops. Even if you are on the other island. Do you see the loadscreen for the next level at all?

    Have you installed the COOP mod? If so, you need to back up your saved games and reinstall.
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •