Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: H6 release v : can't start the game | Forums

Launch trailer - Might & Magic® X Legacy [UK]

Might & Magic X - Legacy - 4 New Classes Speed Painting trailer [UK]

Might and Magic X Legacy - The Gameplay trailer [UK]

Might & Magic X Legacy -- The Open Dev starts! [EUROPE]

  1. #11
    Junior Member
    Join Date
    Oct 2011
    Posts
    4
    Hey,
    After several uninstalls and re-installations i also uninstalled the Ubisoft Game Launcher (UGL). After that i installed the game (which probably installs the latest version of UGL) and now it works
    The only problem i have now is that when i enter the game i'm not online. It's saying that "the passed-in key does not activate the expected privilage". Anyone knows something about this. I think i might have entered the wrong key (but the application accepted it !!!).
    Thanks and i hope the game will work for all of you.
    Reply With Quote Reply With Quote

  2. #12
    Junior Member
    Join Date
    Oct 2011
    Posts
    6
    Having the same problem as Vimonks.

    It dies at the splash screen despite all these fixes.
    Reply With Quote Reply With Quote

  3. #13
    Junior Member
    Join Date
    Mar 2012
    Posts
    1
    My game wont respond AT ALL!!!! When i start it, it goes smoothly... until the game starts. then, my computer stops working, and i have to force quit! HELP!
    Reply With Quote Reply With Quote

  4. #14
    Junior Member
    Join Date
    Jul 2013
    Posts
    1
    stuck with splash screen and messages that the game is already running.
    interesting to see that this is a two year old problem that ubisoft never bothered to fix.
    Update drivers? thats a poor excuse to direct attention away from faulty programming and no game support.
    Would love to hear if anyone has a working solution.
    Reply With Quote Reply With Quote

  5. #15
    UK Forum Manager Ubi-Mush's Avatar
    Join Date
    Nov 2011
    Location
    E. Sussex, UK
    Posts
    15,865
    Hi and welcome to the forums, please open a ticket with Technical Support, the link is in my signature.
    Ubisoft UK Forum Manager

    Technical Support
    Twitter Support
    Facebook Support

    Reply With Quote Reply With Quote

  6. #16
    Junior Member
    Join Date
    Nov 2012
    Posts
    1

    hey

    Quote Originally Posted by Ubi-Mush View Post
    Hi and welcome to the forums, please open a ticket with Technical Support, the link is in my signature.
    hey thanks, but when i even tried to write a question to you, your stupid website has errors too, GO FIGURE.
    Reply With Quote Reply With Quote

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •