Results 1 to 4 of 4

Thread: Can no longer launch Myst (Mac) | Forums

  1. #1
    Junior Member
    Join Date
    Oct 2004
    Posts
    3
    PowerMac DP 1.25 Ghz
    RadeonPro 9000
    1.5GB RAM
    Mac OS X 10.3.5

    Demo worked great.
    Full game worked flawlessly for two full days until...

    In Haven, Achenar's crows nest- clicked on telescope and BOOM!
    Myst IV unexpectedly quit and now will no longer launch at all.

    I'd really like to be able to play this game again.

    Since this crash, when I try to launch, it looks like resolution is trying to switch to 640x480 just before it quits ?!?

    The "detect_config_dsc" file that is being created looks like this (even though I had been playing at 1024x728):
    <pre class="ip-ubbcode-code-pre">;
    ;OSX system environment
    ;

    {system
    frequency ( 1192 )
    }
    {Detection
    {GameOptions
    MaximumResX ( 800 )
    MaximumResY ( 600 )
    SuggestedResX ( 640 )
    SuggestedResY (480)
    GraphicsQuality (0)
    }
    }
    </pre>
    I tried changing max res and suggested res in this file, but it simply reverts back to the above every time I attempt to launch the game.

    Is there any way to edit this file and have it "stick"?

    Crash.log:
    <pre class="ip-ubbcode-code-pre">
    Thread: 0

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_INVALID_ADDRESS (0x0001) at 0xff3f4375

    Thread 0 Crashed:
    0 com.ubisoft.myst4 0x001ec178 0x1000 + 0x1eb178
    1 com.ubisoft.myst4 0x001e0674 0x1000 + 0x1df674
    2 com.ubisoft.myst4 0x0019c064 0x1000 + 0x19b064
    3 com.ubisoft.myst4 0x0019c5c8 0x1000 + 0x19b5c8
    4 com.ubisoft.myst4 0x00222180 0x1000 + 0x221180
    5 com.ubisoft.myst4 0x0021f8f0 0x1000 + 0x21e8f0
    6 com.ubisoft.myst4 0x0009a634 0x1000 + 0x99634
    7 com.apple.CoreFoundation 0x901946a8 __CFRunLoopDoTimer + 0xf4
    8 com.apple.CoreFoundation 0x90191a08 __CFRunLoopRun + 0x5c8
    9 com.apple.CoreFoundation 0x90195f1c CFRunLoopRunSpecific + 0x148
    10 com.apple.HIToolbox 0x927d5f88 RunCurrentEventLoopInMode + 0xac
    11 com.apple.HIToolbox 0x927dc6f0 ReceiveNextEventCommon + 0x17c
    12 com.apple.HIToolbox 0x927fe1c8 AcquireNextEventInMode + 0x48
    13 com.apple.HIToolbox 0x927fb698 RunApplicationEventLoop + 0x88
    14 com.ubisoft.myst4 0x0009b528 0x1000 + 0x9a528
    15 com.ubisoft.myst4 0x00005618 0x1000 + 0x4618
    16 com.ubisoft.myst4 0x000048a0 0x1000 + 0x38a0
    17 com.ubisoft.myst4 0x000046d0 0x1000 + 0x36d0
    </pre>

    I guess my next step is to try to re-install.
    Thanx for any help.
    Reply With Quote Reply With Quote

  2. #2
    Junior Member
    Join Date
    Oct 2004
    Posts
    3
    PowerMac DP 1.25 Ghz
    RadeonPro 9000
    1.5GB RAM
    Mac OS X 10.3.5

    Demo worked great.
    Full game worked flawlessly for two full days until...

    In Haven, Achenar's crows nest- clicked on telescope and BOOM!
    Myst IV unexpectedly quit and now will no longer launch at all.

    I'd really like to be able to play this game again.

    Since this crash, when I try to launch, it looks like resolution is trying to switch to 640x480 just before it quits ?!?

    The "detect_config_dsc" file that is being created looks like this (even though I had been playing at 1024x728):
    <pre class="ip-ubbcode-code-pre">;
    ;OSX system environment
    ;

    {system
    frequency ( 1192 )
    }
    {Detection
    {GameOptions
    MaximumResX ( 800 )
    MaximumResY ( 600 )
    SuggestedResX ( 640 )
    SuggestedResY (480)
    GraphicsQuality (0)
    }
    }
    </pre>
    I tried changing max res and suggested res in this file, but it simply reverts back to the above every time I attempt to launch the game.

    Is there any way to edit this file and have it "stick"?

    Crash.log:
    <pre class="ip-ubbcode-code-pre">
    Thread: 0

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_INVALID_ADDRESS (0x0001) at 0xff3f4375

    Thread 0 Crashed:
    0 com.ubisoft.myst4 0x001ec178 0x1000 + 0x1eb178
    1 com.ubisoft.myst4 0x001e0674 0x1000 + 0x1df674
    2 com.ubisoft.myst4 0x0019c064 0x1000 + 0x19b064
    3 com.ubisoft.myst4 0x0019c5c8 0x1000 + 0x19b5c8
    4 com.ubisoft.myst4 0x00222180 0x1000 + 0x221180
    5 com.ubisoft.myst4 0x0021f8f0 0x1000 + 0x21e8f0
    6 com.ubisoft.myst4 0x0009a634 0x1000 + 0x99634
    7 com.apple.CoreFoundation 0x901946a8 __CFRunLoopDoTimer + 0xf4
    8 com.apple.CoreFoundation 0x90191a08 __CFRunLoopRun + 0x5c8
    9 com.apple.CoreFoundation 0x90195f1c CFRunLoopRunSpecific + 0x148
    10 com.apple.HIToolbox 0x927d5f88 RunCurrentEventLoopInMode + 0xac
    11 com.apple.HIToolbox 0x927dc6f0 ReceiveNextEventCommon + 0x17c
    12 com.apple.HIToolbox 0x927fe1c8 AcquireNextEventInMode + 0x48
    13 com.apple.HIToolbox 0x927fb698 RunApplicationEventLoop + 0x88
    14 com.ubisoft.myst4 0x0009b528 0x1000 + 0x9a528
    15 com.ubisoft.myst4 0x00005618 0x1000 + 0x4618
    16 com.ubisoft.myst4 0x000048a0 0x1000 + 0x38a0
    17 com.ubisoft.myst4 0x000046d0 0x1000 + 0x36d0
    </pre>

    I guess my next step is to try to re-install.
    Thanx for any help.
    Reply With Quote Reply With Quote

  3. #3
    I'm by no means an expert on a mac, but if you have a way to reinstall video drivers, do so. It looks like they're incorrectly accessing the mac kernel...

    Otherwise, yeah, a reinstall would be good too! ^_^
    Reply With Quote Reply With Quote

  4. #4
    Junior Member
    Join Date
    Oct 2004
    Posts
    3
    Update:

    Un/Re-installing did nothing.
    Myst still quits on launch.

    I guess I can try re-installing video drivers...
    It's kind of a pain, because you can't download them from ATi-- they're included in the OS.

    I don't understand how this application could have whacked my video drivers...
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •