Page 2 of 16 FirstFirst 123412 ... LastLast
Results 11 to 20 of 151

Thread: [Mac] Myst III Universal Installer | Forums

  1. #11
    Junior Member
    Join Date
    Jan 2012
    Posts
    3
    Quote Originally Posted by Gannet7 View Post
    Hi pyrokld,
    The windowed mode is only available in the Cider version, which runs on 10.7. I don't think there's any way to make the normal version run in a window.
    Bummer, any way to force Cider version? (I am moderately familiar with editing application resources)
    Reply With Quote Reply With Quote

  2. #12
    Yes, you can edit 'Contents/MacOS/Myst III Exile' which is a bash script controlling the launch. The first line reads:
    if [[ $(sw_vers -productVersion | cut -d . -f 2) < 7 ]]
    If you change the 7 to a 6 then Cider will be used on 10.6 as well. However you'll want to switch back while playing Edanna which has problems in Cider as mentioned in the first post.
    Reply With Quote Reply With Quote

  3. #13
    Junior Member
    Join Date
    Jan 2012
    Posts
    3
    Awesome, thanks! Trying to play full screen on a 23" is just painful.
    Reply With Quote Reply With Quote

  4. #14
    Junior Member
    Join Date
    Apr 2012
    Posts
    3
    Hi Gannet7,

    Congratulations on the installer - a seamless solution to a problem that would have ruined the Myst series for me forever!

    However, I am having a few problems. Firstly, do you know any solution to the faulty lens and reflector plants in Edanna?
    Reply With Quote Reply With Quote

  5. #15
    No solution yet. I assure you, if there was one I would have posted about it ;-)
    Reply With Quote Reply With Quote

  6. #16
    Hi there Gannet7.

    I attempted this install with both the DVD and CD versions of Myst III. I tried the DVD version first and saw nothing wrong until I got the problem where you can't use the reflector plants in Edanna. ( Although I did find that the first sunflower looking plant can be positioned properly when the sunlight is blocked, which makes for an easier time. )

    I then attempted to install it from CD and right off the fence I notice a problem; the sound is very buggy... It's very full of static and buzzing noises and makes playing with the sound on a very annoying experience, which isn't good because I really enjoy the music and sounds of the game. I hadn't gotten the chance to see if the reflector plants still didn't work right but I'm going to guess that they don't...
    Do you know what the problem could be with the sound?

    ( However I'm pleased to note that the Myst IV installer works flawlessly. c: )
    Last edited by SupahSpencer; 04-16-2012 at 09:29 PM.
    Reply With Quote Reply With Quote

  7. #17
    Hi,
    Thanks for your feedback. I'm afraid I have no idea what might be causing the sound problem - the CD and DVD versions have identical data except that the DVD data contains more languages than the CD, so it seems strange. Are you using English or something else? Unfortunately I don't have the CD version to test any more but I do know it will give you the exact same problem with the plants - I'd suggest you stick with the DVD version.
    Reply With Quote Reply With Quote

  8. #18
    That's interesting... Yes, I'm using English. I guess I will just stick to the DVD version, then, since the sound is okay in it.
    I did notice something interesting when the game was starting up that might shed some light on the situation, but I don't have the game installed on this current computer so I can't say what it was now. I may update when I get home.

    EDIT: I ran Exile so that I could see the terminal and I got loads of error messages, most pertaining to sound... Here they are, made smaller to save space:
    err:wave_audiodevice:audio_device_stereo_channels device 71 failed to get preferred stereo channels (0x77686f3f)
    err:wave_audiodevice:audio_device_channel_volume_w ritable device 71 failed to get volume writable (0x77686f3f)
    err:wave_audiodevice:audio_device_format failed to get device 71 format inputChannel: 0 (0x77686f3f)
    err:wave_audiodevice:audio_device_stereo_channels device 91 failed to get preferred stereo channels (0x77686f3f)
    err:wave_audiodevice:audio_device_channel_volume_w ritable device 91 failed to get volume writable (0x77686f3f)
    err:wave_audiodevice:audio_device_format failed to get device 91 format inputChannel: 0 (0x77686f3f)
    err:wave_audiodevice:audio_device_channel_volume_w ritable device 33 failed to get volume writable (0x77686f3f)
    err:wave_audiodevice:audio_device_format failed to get device 61 format inputChannel: 1 (0x77686f3f)
    err:module:BUILTIN32_dlopen failed to load .so lib for builtin msacm.drv: dlopen(/Applications/Myst III Exile.app/Contents/Frameworks/libmsacm.drv.dylib, 2): image not found
    err:module:BUILTIN32_dlopen failed to load .so lib for builtin msacm.drv: dlopen(/Applications/Myst III Exile.app/Contents/Frameworks/libmsacm.drv.dylib, 2): image not found
    err:module:BUILTIN32_dlopen failed to load .so lib for builtin midimap.drv: dlopen(/Applications/Myst III Exile.app/Contents/Frameworks/libmidimap.drv.dylib, 2): image not found
    err:module:BUILTIN32_dlopen failed to load .so lib for builtin midimap.drv: dlopen(/Applications/Myst III Exile.app/Contents/Frameworks/libmidimap.drv.dylib, 2): image not found
    err:font:WineEngAddFontResourceEx can't without FreeType support!
    err:font:WineEngAddFontResourceEx can't without FreeType support!
    err:module:BUILTIN32_dlopen failed to load .so lib for builtin dsound.dll: dlopen(/Applications/Myst III Exile.app/Contents/Frameworks/libdsound.dylib, 2): image not found
    err:module:BUILTIN32_dlopen failed to load .so lib for builtin dsound.dll: dlopen(/Applications/Myst III Exile.app/Contents/Frameworks/libdsound.dylib, 2): image not found
    err:module:BUILTIN32_dlopen failed to load .so lib for builtin dsound.dll: dlopen(/Applications/Myst III Exile.app/Contents/Frameworks/libdsound.dylib, 2): image not found
    err:module:BUILTIN32_dlopen failed to load .so lib for builtin dsound.dll: dlopen(/Applications/Myst III Exile.app/Contents/Frameworks/libdsound.dylib, 2): image not found
    err:macdrv_gl:MACDRV_GL_UpdateSurfaceTexture glGetError returns 0x502 for creating/updating surface textureerr:heap:NewRtlFreeHeap block 0x1760008 isn't a valid part of heap 0x706776b0
    err:heap:NewRtlFreeHeap block 0x1460008 isn't a valid part of heap 0x706776b0
    err:heap:NewRtlFreeHeap block 0x1460008 isn't a valid part of heap 0x706776b0


    Not sure what it all means, just wanted to post in case it would help shed some light on the situation.
    Last edited by SupahSpencer; 04-17-2012 at 08:19 PM.
    Reply With Quote Reply With Quote

  9. #19
    Is that from DVD or CD, or are they both the same? Most of that looks pretty normal, I'd only be suspicious if there was a difference between the DVD and CD editions.
    Reply With Quote Reply With Quote

  10. #20
    Junior Member
    Join Date
    Apr 2012
    Posts
    3
    In an attempt to bypass the Edanna issue I tried to run Exile on an old PowerPC mac computer that I have using the save files from the game on my Intel mac but I cannot seem to find the save files for my games at the location you supplied - no "Myst III Exile" folder exists at Library/Application Support. I have run multiple searches through the entirety of my computer with the names of the save files and it seems they are nowhere to be found...I installed the game a second time (in a different folder location) and again, no save files or save folder was located. However it appears that both installations of the game share my save files when I play the game - indicating that the files exist somewhere on my system.

    I opened the package contents of the game itself and found an alias (Myst III Exile/Contents/Resources/Saved Games) which appears to link to the Saved Games folder but double clicking the alias results in the following error message: "The operation can’t be completed because the original item for “Saved Games” can’t be found."

    Do you know where I might be able to find the elusive save files? If it helps, I am running OS X 10.8 (Mountain Lion) and I have the DVD version of Exile.
    Reply With Quote Reply With Quote

Page 2 of 16 FirstFirst 123412 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •