Results 1 to 3 of 3

Thread: H6b : crash after Uplay screen | Forums

Launch trailer - Might & Magic® X Legacy [UK]

Might & Magic X - Legacy - 4 New Classes Speed Painting trailer [UK]

Might and Magic X Legacy - The Gameplay trailer [UK]

Might & Magic X Legacy -- The Open Dev starts! [EUROPE]

  1. #1
    Game crash after Uplay screen

    I think this has something to do with the update as it worked fine before, but now after I run the game from steam and the Uplay might and magic screen pops up, if i hit play the game just crashes and windows says it's found a problem and closes it.

    I'm running vista with a AMD 2.2 quad core and 4 gigs of ram and dual 512(i think) MB video cards.
    Reply With Quote Reply With Quote

  2. #2
    Game crash after Uplay screen

    I think this has something to do with the update as it worked fine before, but now after I run the game from steam and the Uplay might and magic screen pops up, if i hit play the game just crashes and windows says it's found a problem and closes it.

    I'm running vista with a AMD 2.2 quad core and 4 gigs of ram and dual 512(i think) MB video cards.
    Reply With Quote Reply With Quote

  3. #3
    I, also, run the game from Steam : no problem for me, after 1.4 update.

    By the way : "dual 512 MB video cards" does not give us the exact brand & model number of the cards.
    [color:PURPLE]sig > Mod edits may not be altered. Mod actions may not be quoted or discussed : send a PM.[/color]
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •