Page 1 of 12 12311 ... LastLast
Results 1 to 10 of 116

Thread: AC2 PC - Game freezes | Forums

Assassin's Creed Unity Revolution Gameplay Trailer [US]

Assassin's Creed Unity Official E3 2014 Co-op Commented Demo [US]

Assassin's Creed Unity: Introduction to Arno [US]

Assassin's Creed Unity E3 2014 World Premiere Cinematic Trailer [US]

  1. #1
    Junior Member
    Join Date
    Mar 2010
    Posts
    13
    I wish i could say this is a great game but i have a major problem with it , The game freezes and locks up the entire computer no alt tabbing ctrl alt deling nothing works untill i turn the pc off. I have never had any problems with any other games with this set up so i have come to the conclusion that it is AC2 locking it up.

    Quick system specs:

    3ghz quad core extreme
    8gig ddr3 ram
    geforce 260gtx
    plenty of hdd space
    yadda yadda

    Anyone else getting this problem?
    Reply With Quote Reply With Quote

  2. #2
    I am having the exact same problem!
    I mujst say that this ruins the game for me,having to restart my computer everytime the game freezes.

    It usually happens when it loads a save or when i go from one area to another.
    The freezes doesbt seem to have anny obvious pattern and might be difficult to reproduse.

    But i can say that its *<span class="ev_code_PINK">*fluffy bunnies*</span> annoying when you are in the middle of a hunt or tryng to figure out some hard-to-catch details!

    Rig specs:
    E8400 @ 3.0 ghz
    4gb of RAM
    HD 4850
    plenty of diskspace and all the other goodies

    PS: Where can i find the code that unlocks Battle of Forli and Bonfires of the Vatines??
    Reply With Quote Reply With Quote

  3. #3
    Junior Member
    Join Date
    Mar 2010
    Posts
    13
    Its extremly frustrating. I hate having to power down my pc like that just cause a game screws up!

    Any ideas Ubisoft???????????

    Either give us a fix or a refund cause this is just rubbish.
    Reply With Quote Reply With Quote

  4. #4
    I have the same problem, five times in 15 minutes, game is unplayable, what a waste of money for something I have really looked foreward to. PC is not the issue it is more than capable.

    So give me a fix ubi or money back, where else in the world can you sell something that does not work and then refuse to help, its pathetic, last game i buy from these amateurs
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    Mar 2010
    Posts
    10
    I know how fking annoying that is, same problem with my game... -.-

    My comp might just might be the problem aswell:
    64 X2 3800+
    3,3Gig RAM
    GeForce 9300 GE

    My comp is ****, I know, but it's the same exact problem.

    Mine freezes everytime when I go to the assassins tomb in the lil country side town, don't remember the towns name.

    The game froze once earlier, but it was just once. And now, everytime I get to the tomb and past the wine cellar, it freezes.

    So if there is a solution I'd like to know that as soon as possible!
    Reply With Quote Reply With Quote

  6. #6
    Heyhey, It seems I'm not the only one have such a crippy problem. first of all i thought it might be my hardware problem...but after i upgrade my ram and graphic card. the problem remains. everytime whenever loading to the new senquence. the game freezed and i have to restart the whole computer...

    UBISOFT..please really really concern about your consumer's problem. we are not paying for the **** rubbish!!!
    Reply With Quote Reply With Quote

  7. #7
    Junior Member
    Join Date
    Mar 2010
    Posts
    2
    Same S#IT here...
    It just keep freezing with no apparent reason!
    Sometime it freeze a few min after I launch the game... sometime after 1h or more.
    Not to mention the idiotic mouse acceleration that "entertain" me while waiting for the next crash...
    QX9650
    4 Gigs ram
    GTX295
    ..and a rubbish game!!!
    Reply With Quote Reply With Quote

  8. #8
    Senior Member AnthonyA85's Avatar
    Join Date
    Mar 2010
    Location
    South Yorkshire, England
    Posts
    1,528
    Same here. My computer is more than capable of running this game with everything on high.

    I've had absolutely NO problems with AC1 whatsoever, apart from a few random CTDs here and there, but nothing like this.

    Every time it's happened now, it's happening when I leave the map, it fades to white and goes no further.

    First time it happened was last night just as the first Sequence finished and it faded to white, then froze.

    I can't use the map now becase every time i try to come out of it, this happens. I've had to restart my system more or less every time.

    Ubisoft better fix this, because if this happens to people in the states when the US release date comes, Ubisoft are going to get even more greif.

    I'm considering asking my brother to take this back and get me the ps3 version, since he has a PS3.
    "I'll cleave ya lengthwise! Maggots!" - Edward "Blackbeard" Thatch.
    Reply With Quote Reply With Quote

  9. #9
    Junior Member
    Join Date
    Mar 2010
    Posts
    13
    Its good to see(well not really i guess..) that others have the same problem.

    Can we get some help?
    Reply With Quote Reply With Quote

  10. #10
    __________________________________________________ _____________________________________________

    Have you ALL tried running the game On 2 CPU cores, or even 1 core (depending on your processor i.e. Quad/Dual) ? (Though You shouldn't have any problem playing the game on a Dual-Core CPU). NOT sure if this can solve your problem, but there is no harm in trying it. I don't have this game, so I can't test this at my end. @Anthony85, what are your System Specs ?

    **Try disabling 2 CPU cores while playing the game. You can also try to run the game on a SINGLE core, if this fails.

    After you have loaded the Game's Main Menu, Open Task Manager (CTRL+ALT+DEL/CTRL+SHIFT+ESC) and Click on the Processes Tab. On the Processes tab, at the bottom click on the 'Show processes from all users' Button. Now Right click the process i.e. AssassinsCreedIIGame.exe, and Click on the 'Set Affinity' option, and then 'Uncheck' any 2 boxes labelled as CPU 0, CPU 1 etc., and click on the OK button. But first Launch the game and then press 'ALT-TAB' to go back to the desktop, and now open the Task Manager, and follow the above method. Press 'ALT-TAB' to go back to the game.

    Just make sure to run the process i.e. AssassinsCreedIIGame.exe, with any 2 cores of the CPU. Or Uncheck any 3 boxes, to play the game on a Single CPU core.

    **Another method: Insert the following command inside the Target line at the game's Shortcut TAB. Make a Shortcut of the game's .EXE and insert the following command (Right-click---->Go to properties---->Shortcut TAB):

    C:\Windows\System32\cmd.exe /c start /HIGH /affinity 3 AssassinsCreedIIGame.exe

    This will allow the game to run on High priority, and only on 2 CPU cores. There is another syntax which we can use: C:\Windows\System32\cmd.exe /c start “NameofExecutable.exe” /PRIORITY /AFFINITY # “Shortcut's path”. You can also Lower the process priority if needed.

    C:\Windows\System32\cmd.exe /c start /HIGH /affinity 1 AssassinsCreedIIGame.exe

    This will allow the game to run on High priority, and only on 1 CPU core.

    I don't suggest giving the Process, a Higher Priority under Windows 7, because of better Memory Utilization. You can also use this tool for setting the CPU affinity/priority:

    http://edgemeal.110mb.com/PriFinitty/index.htm

    You can also try running the Game's .exe/Game's Launcher as an 'Administrator', and also under 'Windows XP/Vista Compatibility mode' (If using Windows 7). Btw, which OS are you all using ? Kindly specify it. And one more thing: Disable Anti-Aliasing (AA) as well as VSync at the game's VIDEO/Graphics Menu options. Turn them OFF.


    //* You also need to wait for ATI/Nvidia to release new Updated Drivers for their Graphic Cards. They usually test and release new Optimised drivers which increase some performance in latest PC titles. Though this is NOT always the case, but I'm just telling. Btw, also download the latest GPU drivers.


    __________________________________________________ _______________________________________________



    Reply With Quote Reply With Quote

Page 1 of 12 12311 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •