Results 1 to 5 of 5

Thread: H6 release v : stuck on launch screen | Forums

Launch trailer - Might & Magic® X Legacy [UK]

Might & Magic X - Legacy - 4 New Classes Speed Painting trailer [UK]

Might and Magic X Legacy - The Gameplay trailer [UK]

Might & Magic X Legacy -- The Open Dev starts! [EUROPE]

  1. #1
    Junior Member
    Join Date
    Sep 2011
    Posts
    11
    Same as beta, not responding upon launch

    This is same stuff happening all over as in beta 1.4. What's the point in purchasing the game if the game finds 'zero' updates, proceeds to launch and then gets stuck on launch screen stating its unresponsive. The hell? I will not play on some stupid 600x480 settings.
    Reply With Quote Reply With Quote

  2. #2
    Junior Member
    Join Date
    Aug 2008
    Posts
    26
    Did you check with your firewall ? or it is also possible you have some kind of software like peerguardian that may be blocking the game connection.
    Reply With Quote Reply With Quote

  3. #3
    Junior Member
    Join Date
    Oct 2011
    Posts
    14
    Go to your game folder and use the GU aplication it worked for me will update u to 1.1 whut operation sistem u are ussing? it will help give us more information
    Reply With Quote Reply With Quote

  4. #4
    Junior Member
    Join Date
    Sep 2011
    Posts
    11
    There's no firewall put up, I've checked. Also it worked on the 4th try to get the game to launch (as it did in beta). I just hope it won't keep on doing this - I'll post more if it keeps happening and try to see why.
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    Sep 2011
    Posts
    11
    give us more
    I'm running the game from steam, and therefore cant really update manually, not to my knowledge at least .
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •