Results 1 to 6 of 6

Thread: Unable to play Assassin's Creed 2 (internet connection is required to play this game) | Forums

The Assassin's Creed Experience - Comic-Con Day 3

Assassin?s Creed Unity Arno Master Assassin CG Trailer [US]

The Assassin's Creed Experience - Comic-Con Day 2

The Assassin's Creed Experience - Comic-Con Day 1

  1. #1
    Junior Member
    Join Date
    Jan 2011
    Posts
    5
    Earlier today I purchased Assassin's Creed 2 for PC from Steam. I swore never to purchase another Ubisoft game that uses DRM again after the problems I had with SC: Conviction (the DRM kept kicking in and pausing the game, it was like playing with a strobe light)... but I digress. I fell for their trap and bought AC2 and after it installed I have been unable to play it. Each time I try to log in I get a message saying:

    An internet connection is required to play this game. Failed to connect to the Ubisoft master servers. Please verify that your internet connection is functional and try again.

    My internet connection is functional (as I am making this post on it from the PC on which I'm trying to play AC2). I have learnt my lesson and will never by *another* Ubisoft game, but I would like to play AC2 and get my moneys worth from it.

    Is there anyway to know whether the servers are actually down? Or are there some fixes to get around this issue?
    Reply With Quote Reply With Quote

  2. #2
    Banned
    Join Date
    Sep 2010
    Posts
    734
    ...........

    1. There is a Link here for this issue, you can give it a read, if you wish:

    http://ubisoft.custhelp.com/cg...E!&p_li=&p_topview=1


    2. Some anti-virus or firewall programs may prevent the Game Launcher from communicating properly with the service. Please make sure that you have updated any anti-virus or personal firewall software you have installed. Some software may need to be uninstalled from your computer to play the game. Programs known to interfere with the Game Launcher:

    ZoneAlarm
    NetLimiter
    Avira
    Komodo
    Hamachi
    Rogers Online Protection
    Ultimate Arena.

    3. You can also give this method a try. Locate the HOSTS.txt file found under this path, 'C:\Windows\System32\drivers\etc'. Open it with any text/notepad, and then delete everything below these two lines of text:

    127.0.0.1 localhost
    ::1 localhost


    After that save this file, and try playing the game again. Also see what happens, if you DELETE this hosts.txt file ?

    4. Try to disable any antivirus software or Windows firewalls to allow the Ubisoft GameLauncher full access. Also check your Router's firewall.

    These are some Online Services Platform Ports:
    80, 13000, 13005, 13200-13999
    (all TCP) if not using web proxy.

    If you are unsure of how ports work, the best course of action may be to contact your router manufacturer, system administrator or ISP for more information. You can also try to bypass the router by plugging directly into the modem to see if the connection error persists.
    Reply With Quote Reply With Quote

  3. #3
    Junior Member
    Join Date
    Jan 2011
    Posts
    5
    Thanks for the reply. The only software I'm running at the moment that I believe could have and effect is peer block (which is currently disabled).

    The windows firewall is disabled and the virus scanner I am using (AVG) doesn't have a built in firewall (though I just tried disabling the resident shield with no success).

    I'll try setting the router to forward those ports to my machine, though I didn't have to do that in the past when I had Splinter Cell Conviction working (which not also doesn't work).
    Reply With Quote Reply With Quote

  4. #4
    Junior Member
    Join Date
    Jan 2011
    Posts
    5
    I thought I had deleted everything from the hosts file, but there was one line I had missed, removing this has now caused the Launcher to update when it starts.

    Hopefully now it will work!
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    Nov 2011
    Posts
    2
    justinpunny you are the best! ac2 is working perfect. i had to disable the firewall and my anti virus which is eset.

    thanks again
    Reply With Quote Reply With Quote

  6. #6
    Junior Member
    Join Date
    Apr 2014
    Posts
    1
    Quote Originally Posted by justinpunny View Post
    ...........

    3. You can also give this method a try. Locate the HOSTS.txt file found under this path, 'C:\Windows\System32\drivers\etc'. Open it with any text/notepad, and then delete everything below these two lines of text:

    127.0.0.1 localhost
    ::1 localhost


    After that save this file, and try playing the game again. Also see what happens, if you DELETE this hosts.txt file ?
    This actually worked with me, I had a problem launching the game. The window showed a message saying my internet connection settings had probably to be changed. And so I followed these easy steps and succeeded! Thank you very much!!!
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •