Results 1 to 4 of 4

Thread: Prince of Persia - the first game's sound effects | Forums

  1. #1
    The first game from Jordan Mechner, called Prince of Persia, was released, I think, in 1989. The sound-track/background/sound effects when playing this game was what I liked a lot. I played the game in 1989-1991.
    Recently, when I tried to play the game again, I was told it would only play with dosbox. I installed dosbox and realised that the sound effects (when picking up the sword, running, opening of the gates etc.) had changed totally.
    All I'm trying to find out is, how to play the old game with the old, original sound effects.
    Hope this helps you isolate my problem.
    I welcome your suggestions,
    Thanks.
    Reply With Quote Reply With Quote

  2. #2
    Most Helpful Prince of Persia Community Member kakalukiaJay's Avatar
    Join Date
    Apr 2004
    Posts
    4,792
    I still play the original game with just standard PC speakers.
    I enjoy the game for its gameplay; so I do not know what is needed for an audiophile.
    Reply With Quote Reply With Quote

  3. #3
    I will be more helpful since you don't have to be an "audiophile" just to enjoy the game as most people experienced it. Mechner didn't put the sound in for audiophiles only, it's for everyone to enjoy.

    I would say just check your DOSBox settings. Use a frontloader like Defend to make it easier on yourself. I use Soundblaster 16 settings usually. From what I remember, long ago, Prince of Persia was always one of the easier DOS games to get fully working with sound.

    If you set it up right, you should hear "oof" when you hit walls or the music when dying or in the intro. You should also hear a cry of pain when hit with a sword.

    Really though, for further help, you might find more specific help at the DOSBox forums.

    You could also try the SNES or Megadrive versions which have full sound and music without much headache. The full Mac version of the first game with all sound intact is on last gens versions of Sands of Time. The SNES version is also available with Forgotten Sands on Wii.
    Reply With Quote Reply With Quote

  4. #4
    I used to have the same problem, the solution is very easy, just go to DOSBOX options and disable the soundblaster card,

    sbtype=none ---Here is the change you need to do and thats it.....
    sbbase=220
    irq=7
    dma=1
    hdma=5
    sbmixer=true
    oplmode=auto
    oplemu=default
    oplrate=44100


    I fully understand this guy feelings, playing with the soundblaster quality spoil the whole thing
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •