Results 1 to 4 of 4

Thread: Slightly OT: CH pro Throttle USB | Forums

  1. #1
    Maybe one of you chaps or chapesses has seen and fixed this issue..

    I'm running winxp (sp2) on a gigabyte m/b and an Athlon 64 3200+, ati 9800 pro, 1.5GB RAM.
    All m/b and hardware drivers and BIOS up to date.
    I built it and I maintain it well, no software or hardware problems otherwise.

    Got one of these nice CH throttles to use with my MSFF2 stick in IL2FB.
    I installed the throttle and control manager software as specified by CH.

    Results:
    1) Windows xp (sp2) sees both the MSFF2 stick and the pro throttle in Game Controllers, and both test out fine. All buttons, hats, sliders are working.
    2) The Control Manager software can't see the pro throttle, however......when I try to use the calibrate button, it reports "No active devices"
    3) In the win xp Control Panel/ system/ hardware/ device manager, there is a CH Products entry (as there should be) and it contains a root, aux1, and aux2 device (as it should) but no pro throttle. The HID keyboard and mouse are also listed under the correct sections, and HID-compliant game controller under the correct section.
    4) I can assign keys and hats in IL2 controls for both the stick and the pro throttle just fine, so windows and directx seem to be working without a problem, but not being able to use the CH Manager severely limits the clever stuff I could do by programming the pro throttle.

    I've posted about this at www.ch-hangar.com and despite a lot of effort from Michael of CH products there, we have not resolved the issue. I have tried the 3.5beta version of Control Manager too, but no change.

    Uninstalled, reinstalled multiple times, using the chdelete utility to clean the registry each time. Removed all other USB devices and reinstalled, no change.

    Has anyone seen and solved this issue? It's very frustrating!

    Steph Larsson
    Vancouver's Island
    At or about L 48â? 26.06'N, Lo 123â? 19.31'W
    http://www.stephsdigitals.com
    Reply With Quote Reply With Quote

  2. #2
    Maybe one of you chaps or chapesses has seen and fixed this issue..

    I'm running winxp (sp2) on a gigabyte m/b and an Athlon 64 3200+, ati 9800 pro, 1.5GB RAM.
    All m/b and hardware drivers and BIOS up to date.
    I built it and I maintain it well, no software or hardware problems otherwise.

    Got one of these nice CH throttles to use with my MSFF2 stick in IL2FB.
    I installed the throttle and control manager software as specified by CH.

    Results:
    1) Windows xp (sp2) sees both the MSFF2 stick and the pro throttle in Game Controllers, and both test out fine. All buttons, hats, sliders are working.
    2) The Control Manager software can't see the pro throttle, however......when I try to use the calibrate button, it reports "No active devices"
    3) In the win xp Control Panel/ system/ hardware/ device manager, there is a CH Products entry (as there should be) and it contains a root, aux1, and aux2 device (as it should) but no pro throttle. The HID keyboard and mouse are also listed under the correct sections, and HID-compliant game controller under the correct section.
    4) I can assign keys and hats in IL2 controls for both the stick and the pro throttle just fine, so windows and directx seem to be working without a problem, but not being able to use the CH Manager severely limits the clever stuff I could do by programming the pro throttle.

    I've posted about this at www.ch-hangar.com and despite a lot of effort from Michael of CH products there, we have not resolved the issue. I have tried the 3.5beta version of Control Manager too, but no change.

    Uninstalled, reinstalled multiple times, using the chdelete utility to clean the registry each time. Removed all other USB devices and reinstalled, no change.

    Has anyone seen and solved this issue? It's very frustrating!

    Steph Larsson
    Vancouver's Island
    At or about L 48â? 26.06'N, Lo 123â? 19.31'W
    http://www.stephsdigitals.com
    Steph Larsson
    Vancouver's Island
    At or about L 48â? 43' 3" N, Lo 123â? 41' 20" W
    http://www.stephsdigitals.com
    Reply With Quote Reply With Quote

  3. #3
    Senior Member steve_v's Avatar
    Join Date
    Apr 2002
    Posts
    7,915
    I've also copied to the General Discussion forum. It is UBIs busiest and your post should get many looks there.

    link: http://forums.ubi.com/eve/forums?a=t...83&m=880006627



    Unofficial Community Created FAQ
    Reply With Quote Reply With Quote

  4. #4
    Thanks Steve

    Steph Larsson
    Vancouver's Island
    At or about L 48â? 26.06'N, Lo 123â? 19.31'W
    http://www.stephsdigitals.com
    Steph Larsson
    Vancouver's Island
    At or about L 48â? 43' 3" N, Lo 123â? 41' 20" W
    http://www.stephsdigitals.com
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •