Results 1 to 3 of 3

Thread: Beyond Good and Evil on Windows 7 | Forums

  1. #1
    Junior Member
    Join Date
    Sep 2010
    Posts
    1
    Okay so I've never been able to play this game after owning it for 6 years. It didn't work on my windows xp cos it didn't meat the minimum requirements. Now I'm trying to use it on my Dell Inspiron 1545 dual core running windows 7. It installs fine, but usually when I try to run it it just flashes black a few times and does nothing. I've got it to work a few times before but the audio is WAY ahead of the video and it has a lot of graphical errors like there's a transparent ball in the center of the screen which appears to be the center of view/horizon line. What can I do to play this awesome game?
    Also I have Moblie Intel(R) 4 series chipset family.
    Reply With Quote Reply With Quote

  2. #2
    -------------------------------------------------------------------------------------------------------------------

    Hiya,

    I'm not sure, but does your Laptop fully meet the Game's requirements ? Please don't get me wrong.

    Actually the main problem here, is your Laptop's integrated/onboard Graphics processor i.e. the Intel 4 Series Express Chipset. The Game may not fully support it, because we need to have at least a 32 MB Video Card, to properly run the game.

    Actually your Graphics processor can cause a bottleneck while Gaming. According to the Official Specs, you need a dedicated Video card, and also Windows 7 is not listed as a Supported OS for this game:

    http://ubisoft.custhelp.com/cg...E!&p_li=&p_topview=1


    So I'm NOT sure whether the Game will run properly on the integrated Graphics processor, as well as under WIN 7. The Game might Lag/stutter. From your post, it looks like the Audio and Video is 'Out of Sync' ? OK, Can you try playing the game on a 'Single' CPU core ? Not sure if this can solve your problem, but there is no harm in trying it.::

    **After you have loaded the Game's Main Menu, Open Task Manager (CTRL+ALT+DEL/CTRL+SHIFT+ESC) and Click on the Processes Tab. On the Processes tab, at the bottom click on the 'Show processes from all users' Button. Now Right click the process i.e. BGE.exe, and Click on the 'Set Affinity' option, and then 'Uncheck' any 1 box labelled as CPU 0, CPU 1 etc., and click on the OK button. But first Launch the Game and then press 'ALT-TAB' to go back to the Desktop, and now open the Task Manager, and follow the above method. Press 'ALT-TAB' to go back to the game.

    Just make sure to run the process i.e. BGE.exe, with any 1 core of the CPU.

    **Another method: Insert the following command inside the Target line at the game's Shortcut TAB. Make a Shortcut of the game's .EXE (BGE.exe) and insert the following command (Right-click---->Go to properties---->Shortcut TAB):

    C:\Windows\System32\cmd.exe /c start /HIGH /affinity 1 BGE.exe

    This will allow the Game to run on High priority, and only on 1 CPU core. There is another syntax which we can use: C:\Windows\System32\cmd.exe /c start “NameofExecutable.exe” /PRIORITY /AFFINITY # “Shortcut's path”. You can also Lower the process priority if needed.

    I don't suggest giving the Process (BGE.exe), a very High Priority under Windows 7, because of better Memory Utilization. You can also use this tool for setting the CPU affinity/priority:

    http://edgemeal.110mb.com/PriFinitty/index.htm

    If you find the Gameplay too FAST, then download this application, and run it during the gameplay:

    http://theunusualsuspect.com/software/process


    Turn VSYNC ON, force it to ON (IF you have this in-game Option). Btw, what in-game Video Settings/'Screen resolution' are you using ? Have you tried to LOWER them down ? Turn OFF Antialiasing/AA. Also at the game's Advanced Settings TAB, 'uncheck' the option HW Vertex Processing (under Manual Compatibility). You can also turn OFF 'W Buffer'/Multi vertex stream, if you encounter Visual Artifacts during the gameplay. And Enable Triple-buffering, SSE etc. Also try launching the Game by clicking on the game's executable i.e. BGE.exe, instead of any other shortcut/Launcher.

    And have you tried Updating the Graphics processor/Sound drivers, as well as the DirectX 9 Libraries ?? You must also fully update your copy of Windows 7.

    You can also try playing the game under, Win XP SP2 Compatibility Mode, IF needed. Try running and installing the Game as an ADMIN, and under Win XP SP2 Compatibility Mode. But I read somewhere that gamers had problem running this Game under Windows 7, due to 'Copy protection' drivers ? But I presume your OS is 32 bit ?? Is your game a RETAIL copy, or a Digital download version (STEAM, D2D etc.) ?? If you have downloaded the Game from STEAM, then I suggest you also try Verifying the Game Cache Files (GCF):

    https://support.steampowered.c...p?ref=2037-QEUH-3335

    You must also PATCH the game to the latest version, if you have not done so:

    http://ubisoft.custhelp.com/cg...E!&p_li=&p_topview=1


    I Hope this helps you somehow ?



    ---------------------------------------------------------------------------------------------------------------
    Reply With Quote Reply With Quote

  3. #3
    Banned
    Join Date
    Dec 2011
    Posts
    4
    [spam]
    Last edited by dom1999; 04-02-2012 at 12:10 AM.
    Reply With Quote Reply With Quote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •