Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Game lagging? | Forums

Assassin?s Creed Unity Season Pass Trailer [US]

Assassin?s Creed Unity Co-Op Gameplay Trailer [US]

Assassin?s Creed Unity Co-op Heist Mission Commented Demo [US]

The Assassin's Creed Experience - Comic-Con Day 3

  1. #1
    Member NBST's Avatar
    Join Date
    Feb 2011
    Location
    London, UK
    Posts
    435
    Hey, guys. I received my copy of ACB today and am extremely happy! the game looks great, but I have a nagging issue.

    Annoyingly, the game lags on my laptop. Here are my specs:

    4GB RAM
    2.7 Ghz Intel i5 (quad-core)
    Nvidia GeForce GT 425M

    Now, the reason why I am particularly annoyed is because AC2, on the other hand, runs like butter. Honestly, it doesn't lag AT ALL. I would suppose that there are only minor graphical enhancements implemented in ACB (as far as i've seen), so the performace shouldn't drop dramatically. But it does. Lowering the resolution and the graphics settings helps a bit, but the game still lags.

    Honestly, this is a pretty powerful laptop and the game shouldn't lag on it, in my opinion. In my mind, this point to bad PC optimisation.

    Patch and drivers update didn't help either.

    Any ideas?
    Reply With Quote Reply With Quote

  2. #2
    Senior Member
    Join Date
    Dec 2010
    Posts
    1,507
    Lag as in how many FPS?
    Reply With Quote Reply With Quote

  3. #3
    Member NBST's Avatar
    Join Date
    Feb 2011
    Location
    London, UK
    Posts
    435
    As I said, I did try reducing all graphics settings by about 1 or 2 levels, but it didn't help much.

    Er.. how should I check the FPS?
    Reply With Quote Reply With Quote

  4. #4
    Senior Member Murcuseo's Avatar
    Join Date
    Mar 2010
    Posts
    2,206
    Download a benchmark tool like Fraps. Run fraps then start the game, the benchmark should run in yellow, I think it's top left by default.
    Reply With Quote Reply With Quote

  5. #5
    Member NBST's Avatar
    Join Date
    Feb 2011
    Location
    London, UK
    Posts
    435
    OK, I'll do that.

    In the mean time, I reduced some of the graphics options by 2 levels and the game runs acceptably smooth now. However, in my opinion, I shouldn't have to reduce the graphics options this much, if at all, for the game to run ok, again having in mind how AC2 runs on my PC.
    Reply With Quote Reply With Quote

  6. #6
    ---------------------------------------------------------------------------------------

    As a side note, have you tried running/playing the game On 2 CPU cores, or even 1 core (depending on your processor i.e. Quad CPU) ? Not sure if this can solve your problem, but there is no harm in trying it.

    After you have loaded the Game's Main Menu, Open Task Manager (CTRL+ALT+DEL/CTRL+SHIFT+ESC) and Click on the Processes Tab. On the Processes tab, at the bottom click on the 'Show processes from all users' Button. Now Right click the process i.e. ACBSP.exe, and Click on the 'Set Affinity' option, and then 'Uncheck' any 2 boxes labelled as CPU 0, CPU 1 etc., and click on the OK button. But first Launch the game and then press 'ALT-TAB' to go back to the desktop, and now open the Task Manager, and follow the above method. Press 'ALT-TAB' to go back to the game.

    Just make sure to run the process i.e. ACBSP.exe, with any 2 cores of the CPU. Or Uncheck any 3 boxes, to play the game on a Single CPU core. Btw, does the game fully utilize all the CPU cores ??

    Another method: Insert the following command inside the Target line at the game's Shortcut TAB. Make a Shortcut of the game's .EXE and insert the following command (Right-click---->Go to properties---->Shortcut TAB):

    C:\Windows\System32\cmd.exe /c start /HIGH /affinity 3 ACBSP.exe

    This will allow the game to run on High priority, and only on 2 CPU cores. You can also Lower the process priority if needed. You can also use this tool for setting the CPU affinity/priority:

    http://edgemeal.110mb.com/PriFinitty/index.htm

    As a side note, also try launching the game under 'Windows XP SP2 Compatibility Mode', and see if this makes any in-game difference or not ? This can be easily done under Windows 7/Vista. Btw, which OS are you using ?

    The above low FPS/lag could also be a GPU driver issue. Maybe Nvidia and ATI may release a BETA version of drivers for ACB. Try to close every other Background process while gaming.



    ---------------------------------------------------------------------------------------
    Reply With Quote Reply With Quote

  7. #7
    Member NBST's Avatar
    Join Date
    Feb 2011
    Location
    London, UK
    Posts
    435
    PS, I'm running on Windows 7 64 bit.
    Reply With Quote Reply With Quote

  8. #8
    Junior Member
    Join Date
    Mar 2011
    Posts
    4
    Yeah, i have the same problem. My pc is HD5850, AMD phenom 955 and 4 GB of ram. I have heard that this problem is because i'm using AMD processor? Could it be?

    Help to fix this problem. Maybe the author of this game could help?
    Reply With Quote Reply With Quote

  9. #9
    Member NBST's Avatar
    Join Date
    Feb 2011
    Location
    London, UK
    Posts
    435
    Ok, so at the highest settings (inluding 1080p resolution), the game runs at about 14-15 FPS with relatively low action

    When I decrese the settings by 2, it starts running at 23 fps with low action and environment in the background and abotu 19 with high action and/or environment (i.e. city panorama in the background as opposed to a street).
    Reply With Quote Reply With Quote

  10. #10
    Member NBST's Avatar
    Join Date
    Feb 2011
    Location
    London, UK
    Posts
    435
    Ok, tried reducing the number of cores utilized and it didn't make any difference. The game doesn't even use their full processing power whilst on.
    Reply With Quote Reply With Quote

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •