1. #1
    It's tormented me since I first bought HAWX 2, so I decided to dig into the game files in my rage-fueled...rage.

    Go to My Docs > HAWX 2 > Profiles > Playername_Input > keyboard_here

    C&P this:
    SetKey_PC(CYCLEWEAPON, 0, Keyboard, BUTTON, DIK_1);
    SetKey_PC(CYCLEWEAPONREVERSE, 0, Keyboard, BUTTON, DIK_2);

    save

    edit 1 and 2 as you want it.

    It works perfectly. If not...too bad.
     1 people found this helpful
    Share this post

  2. #2
    If that doesn't fix it, make the files "read only" after setting the keys how you want them. That worked for me.
    Share this post

  3. #3
    Kosevich's Avatar Member
    Join Date
    Apr 2016
    Location
    Ukraine, Kiev
    Posts
    95
    Hakugyokurou, thank you very much! It really works even after 6 years!
    Share this post