Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Keyboard problems on mac and other problems | Forums

Assassin?s Creed Unity Season Pass Trailer [US]

Assassin?s Creed Unity Co-Op Gameplay Trailer [US]

Assassin?s Creed Unity Co-op Heist Mission Commented Demo [US]

The Assassin's Creed Experience - Comic-Con Day 3

  1. #1
    At first the keyboard didn't work at all I had to uninstall the game and then I could use the keyboard but after a while it has the same problem every once and a while. It's really annoying also I can't switch windows I have to stay on the game window. I downloaded it for mac and i have mac OS X. I have used two different keyboards doesn't make a difference. Also the desktop icon is just the steam icon I want the actual Assassin Creed Brotherhood icon because it's bad ***.
    Reply With Quote Reply With Quote

  2. #2
    I also have this same problem, my keyboard doesn't work on Mac side.
    Reply With Quote Reply With Quote

  3. #3
    Junior Member
    Join Date
    Sep 2011
    Posts
    1
    Me too. The game is unplayable.
    Reply With Quote Reply With Quote

  4. #4
    Junior Member
    Join Date
    Oct 2011
    Posts
    2
    Yeah this is pretty much unacceptable.

    At first it worked with my after-market Logitech mouse, but not my wired Apple keyboard. I say "OK" and try the wireless keyboard that came with my iMac. For some reason, it worked.

    But when I changed my control configurations in game, all of a sudden my Logitech mouse stopped working. And by not working, I mean that I can no longer get it to pair with my computer. At all.

    I re-open the game to undo the setting that seemed to have caused the issue and... "This is weird", now it's my wired keyboard that works, while the wireless one is unresponsive.

    Currently I can sorta play the game with my Magic Mouse (undesirable) and one keyboard (depending on which one the game prefers to allow at any given point in time).

    My Logitech mouse remains unable to pair with my computer anymore.

    Thanks, Ubisoft.
    Reply With Quote Reply With Quote

  5. #5
    Junior Member
    Join Date
    Oct 2011
    Posts
    2
    For the record, this was *not* an issue with Assassins Creed II. I played that game before on the same Mac with the same set of hardware that is now being rejected by Brotherhood.

    Was Brotherhood re-ported from the console version? It would seem to have been rather hasty, if we're experiencing problems of this sort...
    Reply With Quote Reply With Quote

  6. #6
    Same problem over here. Any one have a fix?
    Reply With Quote Reply With Quote

  7. #7
    Junior Member
    Join Date
    Jan 2012
    Posts
    1
    I also have a terrible time getting the keyboard to work on the mac. It usually takes about 30 minutes to get the game *started*, just quitting, relaunching, rebooting, the game until it finally works.

    I've tried the workaround I've seen elsewhere on the net of shutting down all other apps (and anything that may be listening to keyboard input). I've also tried disabling steam's in-game stuff. There is no clear correlation of these workarounds to when it works. It's just random and only works about 10% of the time.

    Same problem regardless of whether I use internal or external keyboards. (This is on OSX 1.6.8)

    This is not an acceptable level of quality. Can someone from Ubisoft look into this or give us some reliable workarounds?

    Thanks!
    Reply With Quote Reply With Quote

  8. #8
    Same problem here.
    This is not acceptable.
    Reply With Quote Reply With Quote

  9. #9

    Angry So Rediculous!

    Assassin's Creed 2 just will not work with my keyboard. It worked the very first time I opened the game, played it for an hour, and then opened it up the next day, and it didn't work. I discovered that the force close command (Command + Alt + Escape) closes the game for you, and if you have the in game steam menu (for the steam users out there), shift Tab brings up the Steam UI. But NOTHING gets registered to the actual game. So, I completely reinstalled the game, and it worked the first time I opened the game after reinstalling, but now it's not working again. This is some really pathetic porting, and I my opinion of ubisoft was low enough, but this is completely horrendous. Not to mention the amount of other people reporting the same problem (Steam users AND non-steam users). Steam's forums said to come here, and it's not getting me very far. All other apps are closed, but that shouldn't even matter! I've NEVER had to baby a game like this just to get it to work, even on MAC!

    Fix this please! I payed money for your game, and it's WORTHLESS.
    Reply With Quote Reply With Quote

  10. #10
    Junior Member
    Join Date
    Feb 2012
    Posts
    1
    Same deal with me! Assassin's Creed Brotherhood was working just fine for a while with both mouse and keyboard.
    Then after Steam crashed and halted the game two times in a row, the keyboard suddenly stopped working in the game, except for shift+tab (access to steam in-game)
    and Fn + F12 (take snapshots).
    After restarting the mac, still no improvement. In other words, ACB just became totally worthless for me...
    Please, fix this issue, it's such a shame.
    Reply With Quote Reply With Quote

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •